Integer overflow in Google Chrome
Priority MEDIUM 43CWE-190Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-190 and the CVSS impact.
Summary
An integer overflow leading to an incorrect capacity of a buffer in JavaScript in Google Chrome prior to 73.0.3683.75 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page.
Why it matters now
EPSS 0.02327 83rd percentileScored 2026-11-07
Fix Fixed Chrome (Google): 73.0.3683.75Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Chrome | before 73.0.3683.75 | 73.0.3683.75 | Patch available | CNA |
- Chrome VendorGoogle Affected before 73.0.3683.75 Fixed in 73.0.3683.75 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* | before 73.0.3683.75 | Vulnerable | |
| cpe:2.3:o:opensuse:backports:sle-15:*:*:*:*:*:*:* | sle-15 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:* | 15.0 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:42.3:*:*:*:*:*:*:* | 42.3 | Vulnerable | openSUSE |
- cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* Versions before 73.0.3683.75 Vulnerable ·Google
- cpe:2.3:o:opensuse:backports:sle-15:*:*:*:*:*:*:* Versions sle-15 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:* Versions 15.0 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:42.3:*:*:*:*:*:*:* Versions 42.3 Vulnerable ·openSUSE
Remediation
- Fix · CNA Chrome (Google) Fixed in 73.0.3683.75
Red Hat 1 advisory
- RHSA-2019:0708 Released 2019-04-08 · Red Hat rating Importantchromium-browser security update
- Red Hat Enterprise Linux Desktop Supplementary (v. 6) chromium-browser-73.0.3683.75-1.el6_10
- Red Hat Enterprise Linux HPC Node Supplementary (v. 6) chromium-browser-73.0.3683.75-1.el6_10
- Red Hat Enterprise Linux Server Supplementary (v. 6) chromium-browser-73.0.3683.75-1.el6_10
- Red Hat Enterprise Linux Workstation Supplementary (v. 6) chromium-browser-73.0.3683.75-1.el6_10
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux Desktop Supplementary (v. 6) | Fixed | RHSA-2019:0708 |
| Red Hat Enterprise Linux HPC Node Supplementary (v. 6) | Fixed | RHSA-2019:0708 |
| Red Hat Enterprise Linux Server Supplementary (v. 6) | Fixed | RHSA-2019:0708 |
| Red Hat Enterprise Linux Workstation Supplementary (v. 6) | Fixed | RHSA-2019:0708 |
Timeline
- 2026-10-02 Threatist record created from CVE-2019-5790
- 2026-10-03 Alias added: GHSA-hmgh-76wr-9fj3
References
More Google Chrome vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2019-5790 · CVE Program
- CVE-2019-5790 · NVD
- FIRST EPSS
- GHSA-hmgh-76wr-9fj3 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-5790 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences