Forcepoint VPN Client for Windows versions lower than 6.6.1 have an unquoted search path…
Priority LOW 31CWE-428Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-428.
Summary
Forcepoint VPN Client for Windows versions lower than 6.6.1 have an unquoted search path vulnerability. This enables local privilege escalation to SYSTEM user. By default, only local administrators can write executables to the vulnerable directories. Forcepoint thanks Peleg Hadar of SafeBreach Labs for finding this vulnerability and for reporting it to us.
Why it matters now
EPSS 0.00665 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Forcepoint VPN Client for Windows (Forcepoint): 6.6.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Forcepoint | Forcepoint VPN Client for Windows | before 6.6.1 | 6.6.1 | Patch available | CNA |
- Forcepoint VPN Client for Windows VendorForcepoint Affected before 6.6.1 Fixed in 6.6.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:forcepoint:vpn_client:*:*:*:*:*:windows:*:* | before 6.6.1 | Vulnerable | Forcepoint |
- cpe:2.3:a:forcepoint:vpn_client:*:*:*:*:*:windows:*:* Versions before 6.6.1 Vulnerable ·Forcepoint
Remediation
- Fix · CNA Forcepoint VPN Client for Windows (Forcepoint) Fixed in 6.6.1
Timeline
- 2026-10-02 Threatist record created from CVE-2019-6145
- 2026-10-03 Alias added: GHSA-8gxf-72xg-w67c
References
More Forcepoint Vpn Client vulnerabilities
- TI-2025-11642 Local Privilege Escalation in VPN Client CVSS 4.0HIGH 8.5
Sources
- CVE-2019-6145 · CVE Program
- CVE-2019-6145 · NVD
- FIRST EPSS
- GHSA-8gxf-72xg-w67c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences