A vulnerability reported in Lenovo Service Bridge before version 4.1.0.1 could allow cross-site request forgery.
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
A vulnerability reported in Lenovo Service Bridge before version 4.1.0.1 could allow cross-site request forgery.
Why it matters now
EPSS 0.00476 41st percentileScored 2026-11-07
Fix Fixed Service Bridge (Lenovo): 4.1.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Lenovo | Service Bridge | before 4.1.0.1 | 4.1.0.1 | Patch available | CNA |
- Service Bridge VendorLenovo Affected before 4.1.0.1 Fixed in 4.1.0.1 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:lenovo:service_bridge:*:*:*:*:*:*:*:* | before 4.1.0.1 | Vulnerable | Lenovo |
| cpe:2.3:h:lenovo:ideacentre:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Lenovo |
| cpe:2.3:h:lenovo:ideapad:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Lenovo |
| cpe:2.3:h:lenovo:tablet:-:*:*:*:*:windows:*:* | not specified by NVD | Running on | Lenovo |
| cpe:2.3:h:lenovo:thinkcentre:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Lenovo |
| cpe:2.3:h:lenovo:thinkpad:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Lenovo |
| cpe:2.3:h:lenovo:thinkstation:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Lenovo |
| cpe:2.3:h:lenovo:yoga:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Lenovo |
- cpe:2.3:a:lenovo:service_bridge:*:*:*:*:*:*:*:* Versions before 4.1.0.1 Vulnerable ·Lenovo
- cpe:2.3:h:lenovo:ideacentre:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Lenovo
- cpe:2.3:h:lenovo:ideapad:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Lenovo
- cpe:2.3:h:lenovo:tablet:-:*:*:*:*:windows:*:* Versions not specified by NVD Running on ·Lenovo
- cpe:2.3:h:lenovo:thinkcentre:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Lenovo
- cpe:2.3:h:lenovo:thinkpad:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Lenovo
- cpe:2.3:h:lenovo:thinkstation:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Lenovo
- cpe:2.3:h:lenovo:yoga:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Lenovo
Remediation
- Fix · CNA Service Bridge (Lenovo) Fixed in 4.1.0.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Lenovo Service Bridge 4.1.0.1
4 records Highest priority Priority MEDIUM 2 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2019-04369 A vulnerability reported in Lenovo Service Bridge before version 4.1.0.1 could allow remote code execution.Priority MEDIUM 47
- TI-2019-04368 A vulnerability reported in Lenovo Service Bridge before version 4.1.0.1 could allow remote code execution.Priority MEDIUM 47
- TI-2019-04370 A vulnerability reported in Lenovo Service Bridge before version 4.1.0.1 could allow unencrypted downloads over FTP.Priority LOW 34
Timeline
- 2026-10-02 Threatist record created from CVE-2019-6166
- 2026-10-03 Alias added: GHSA-fxv3-4v9h-4x8v
References
More Lenovo Service Bridge vulnerabilities
- TI-2019-04369 A vulnerability reported in Lenovo Service Bridge before version 4.1.0.1 could allow remote code execution. CVSS 3.1CRITICAL 9.8
- TI-2019-04368 A vulnerability reported in Lenovo Service Bridge before version 4.1.0.1 could allow remote code execution. CVSS 3.1CRITICAL 9.8
- TI-2019-04370 A vulnerability reported in Lenovo Service Bridge before version 4.1.0.1 could allow unencrypted downloads over FTP. CVSS 3.1HIGH 7.5
- TI-2026-01321 Uncontrolled search path in Lenovo Service Bridge CVSS 4.0MEDIUM 5.4
Sources
- CVE-2019-6166 · CVE Program
- CVE-2019-6166 · NVD
- FIRST EPSS
- GHSA-fxv3-4v9h-4x8v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences