Read the docs
TI-2019-04531 Aliases CVE-2019-6467GHSA-92q8-7pjj-mpmp

An error in the nxdomain redirect feature can cause BIND to exit with an INSIST assertion failure in query.c

Priority MEDIUM 41CWE-617Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-617.

Summary

A programming error in the nxdomain-redirect feature can cause an assertion failure in query.c if the alternate namespace used by nxdomain-redirect is a descendant of a zone that is served locally. The most likely scenario where this might occur is if the server, in addition to performing NXDOMAIN redirection for recursive clients, is also serving a local copy of the root zone or using mirroring to provide the root zone, although other configurations are also possible. Versions affected: BIND 9.12.0-> 9.12.4, 9.14.0. Also affects all releases in the 9.13 development branch.

Why it matters now

EPSS 0.05564 92nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 9BIND 9.12.0-> 9.12.4, 9.14.0. Also affects all releases in the 9.13 development branch.—No fix listedCNA
  • BIND 9 VendorISC Affected BIND 9.12.0-> 9.12.4, 9.14.0. Also affects all releases in the 9.13 development branch. Fixed in — No fix listed CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*9.12.0 – 9.12.4; 9.13.0 – 9.13.7VulnerableISC
cpe:2.3:a:isc:bind:9.14.0:*:*:*:*:*:*:*9.14.0VulnerableISC
  • cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:* Versions 9.12.0 – 9.12.4; 9.13.0 – 9.13.7 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.14.0:*:*:*:*:*:*:* Versions 9.14.0 Vulnerable ·ISC

Remediation

No fixed version listed by the sources yet.

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 4 products
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-6467
  2. 2026-10-03 Alias added: GHSA-92q8-7pjj-mpmp

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources