Read the docs
TI-2019-04533 Aliases CVE-2019-6469GHSA-qxvj-gg4r-8gwm

BIND Supported Preview Edition can exit with an assertion failure if ECS is in use

Priority LOW 37CWE-617Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-617.

Summary

An error in the EDNS Client Subnet (ECS) feature for recursive resolvers can cause BIND to exit with an assertion failure when processing a response that has malformed RRSIGs. Versions affected: BIND 9.10.5-S1 -> 9.11.6-S1 of BIND 9 Supported Preview Edition.

Why it matters now

EPSS 0.01954 80th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 9 Supported Preview EditionBIND 9.10.5-S1 -> 9.11.6-S1 of BIND 9 Supported Preview Edition.—No fix listedCNA
  • BIND 9 Supported Preview Edition VendorISC Affected BIND 9.10.5-S1 -> 9.11.6-S1 of BIND 9 Supported Preview Edition. Fixed in — No fix listed CNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.10.5:s1:*:*:supported_preview:*:*:*9.10.5 s1VulnerableISC
cpe:2.3:a:isc:bind:9.11.6:s1:*:*:supported_preview:*:*:*9.11.6 s1VulnerableISC
  • cpe:2.3:a:isc:bind:9.10.5:s1:*:*:supported_preview:*:*:* Versions 9.10.5 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.6:s1:*:*:supported_preview:*:*:* Versions 9.11.6 s1 Vulnerable ·ISC

Remediation

No fixed version listed by the sources yet.

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 4 products
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-6469
  2. 2026-10-03 Alias added: GHSA-qxvj-gg4r-8gwm

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources