Read the docs
TI-2019-04537 Aliases CVE-2019-6473GHSA-5gvx-v2fm-q3fv

A packet containing a malformed DUID can cause the kea-dhcp6 server to terminate

Priority LOW 31CWE-617Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-617.

Summary

An invalid hostname option can trigger an assertion failure in the Kea DHCPv4 server process (kea-dhcp4), causing the server process to exit. Versions affected: 1.4.0 to 1.5.0, 1.6.0-beta1, and 1.6.0-beta2.

Why it matters now

EPSS 0.01168 67th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCKea1.4.0 to 1.5.0; 1.6.0-beta1; 1.6.0-beta2—No fix listedCNA
  • Kea VendorISC Affected 1.4.0 to 1.5.0; 1.6.0-beta1; 1.6.0-beta2 Fixed in — No fix listed CNA

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:ics:kea:*:*:*:*:*:*:*:*1.4.0 – 1.5.0VulnerableIcs
cpe:2.3:a:ics:kea:1.6.0:beta1:*:*:*:*:*:*1.6.0 beta1VulnerableIcs
cpe:2.3:a:ics:kea:1.6.0:beta2:*:*:*:*:*:*1.6.0 beta2VulnerableIcs
  • cpe:2.3:a:ics:kea:*:*:*:*:*:*:*:* Versions 1.4.0 – 1.5.0 Vulnerable ·Ics
  • cpe:2.3:a:ics:kea:1.6.0:beta1:*:*:*:*:*:* Versions 1.6.0 beta1 Vulnerable ·Ics
  • cpe:2.3:a:ics:kea:1.6.0:beta2:*:*:*:*:*:* Versions 1.6.0 beta2 Vulnerable ·Ics

Remediation

No fixed version listed by the sources yet.

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-6473
  2. 2026-10-03 Alias added: GHSA-5gvx-v2fm-q3fv

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-1999-00042 Command execution via shell metachars in INN daemon (innd) 1.5 using "newgroup" and… CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2025-27240 Cache poisoning attacks with unsolicited RRs CVSS 3.1HIGH 8.6
See all 285 →

Sources