Read the docs
TI-2019-04541 Aliases CVE-2019-6477GHSA-6q2x-892r-7qm4

TCP-pipelined queries can bypass tcp-clients limit

Priority MEDIUM 40CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-400.

Summary

With pipelining enabled each incoming query on a TCP connection requires a similar resource allocation to a query received via UDP or via TCP without pipelining enabled. A client using a TCP-pipelined connection to a server could consume more resources than the server has been provisioned to handle. When a TCP connection with a large number of pipelined queries is closed, the load on the server releasing these multiple resources can cause it to become unresponsive, even for queries that can be answered authoritatively or from cache. (This is most likely to be perceived as an intermittent server problem).

Why it matters now

EPSS 0.04134 90th percentileScored 2026-11-07
Fix Fixed Red Hat: 2 advisories

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND99.11.6-P1 -> 9.11.12, 9.12.4-P1 -> 9.12.4-P2, 9.14.1 -> 9.14.7, and versions 9.11.5-S6 -> 9.11.12-S1 of BIND 9 Supported Preview Edition. Versions 9.15.0 -> 9.15.5 of the BIND 9.15 development branch are also affected—No fix listedCNA
  • BIND9 VendorISC Affected 9.11.6-P1 -> 9.11.12, 9.12.4-P1 -> 9.12.4-P2, 9.14.1 -> 9.14.7, and versions 9.11.5-S6 -> 9.11.12-S1 of BIND 9 Supported Preview Edition. Versions 9.15.0 -> 9.15.5 of the BIND 9.15 development branch are also affected Fixed in — No fix listed CNA

CPE configurations NVD · 9

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*9.11.7 – 9.11.12; 9.14.1 – 9.14.7; 9.15.0 – 9.15.5VulnerableISC
cpe:2.3:a:isc:bind:9.11.5:s6:*:*:supported_preview:*:*:*9.11.5 s6VulnerableISC
cpe:2.3:a:isc:bind:9.11.6:p1:*:*:*:*:*:*9.11.6 p1VulnerableISC
cpe:2.3:a:isc:bind:9.11.6:rc1:*:*:*:*:*:*9.11.6 rc1VulnerableISC
cpe:2.3:a:isc:bind:9.11.12:s1:*:*:supported_preview:*:*:*9.11.12 s1VulnerableISC
cpe:2.3:a:isc:bind:9.12.4:p1:*:*:*:*:*:*9.12.4 p1VulnerableISC
cpe:2.3:a:isc:bind:9.12.4:p2:*:*:*:*:*:*9.12.4 p2VulnerableISC
cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:*30VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:*31VulnerableFedoraproject
  • cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:* Versions 9.11.7 – 9.11.12; 9.14.1 – 9.14.7; 9.15.0 – 9.15.5 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.5:s6:*:*:supported_preview:*:*:* Versions 9.11.5 s6 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.6:p1:*:*:*:*:*:* Versions 9.11.6 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.6:rc1:*:*:*:*:*:* Versions 9.11.6 rc1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.12:s1:*:*:supported_preview:*:*:* Versions 9.11.12 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.12.4:p1:*:*:*:*:*:* Versions 9.12.4 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.12.4:p2:*:*:*:*:*:* Versions 9.12.4 p2 Vulnerable ·ISC
  • cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject

Remediation

Red Hat 2 advisories

  • RHSA-2020:1845 Released 2020-04-28 · Red Hat rating Moderate
    bind security, bug fix, and enhancement update
    • Red Hat Enterprise Linux AppStream (v. 8) bind-32:9.11.13-3.el8, bind-chroot-32:9.11.13-3.el8, bind-devel-32:9.11.13-3.el8 +12
    • Red Hat Enterprise Linux BaseOS (v. 8) bind-32:9.11.13-3.el8, bind-export-devel-32:9.11.13-3.el8, bind-export-libs-32:9.11.13-3.el8
  • RHSA-2020:1061 Released 2020-03-31 · Red Hat rating Moderate
    bind security and bug fix update
    • Red Hat Enterprise Linux Client (v. 7) bind-32:9.11.4-16.P2.el7, bind-export-libs-32:9.11.4-16.P2.el7, bind-libs-32:9.11.4-16.P2.el7 +3
    • Red Hat Enterprise Linux Client Optional (v. 7) bind-32:9.11.4-16.P2.el7, bind-chroot-32:9.11.4-16.P2.el7, bind-devel-32:9.11.4-16.P2.el7 +8
    • Red Hat Enterprise Linux ComputeNode (v. 7) bind-32:9.11.4-16.P2.el7, bind-export-libs-32:9.11.4-16.P2.el7, bind-libs-32:9.11.4-16.P2.el7 +3
    • Red Hat Enterprise Linux ComputeNode Optional (v. 7) bind-32:9.11.4-16.P2.el7, bind-chroot-32:9.11.4-16.P2.el7, bind-devel-32:9.11.4-16.P2.el7 +8
    • Red Hat Enterprise Linux Server (v. 7) bind-32:9.11.4-16.P2.el7, bind-chroot-32:9.11.4-16.P2.el7, bind-export-libs-32:9.11.4-16.P2.el7 +11
    • Red Hat Enterprise Linux Server Optional (v. 7) bind-devel-32:9.11.4-16.P2.el7, bind-devel-32:9.11.4-16.P2.el7.ppc, bind-export-devel-32:9.11.4-16.P2.el7 +7
    • Red Hat Enterprise Linux Workstation (v. 7) bind-32:9.11.4-16.P2.el7, bind-chroot-32:9.11.4-16.P2.el7, bind-export-libs-32:9.11.4-16.P2.el7 +7
    • Red Hat Enterprise Linux Workstation Optional (v. 7) bind-devel-32:9.11.4-16.P2.el7, bind-export-devel-32:9.11.4-16.P2.el7, bind-lite-devel-32:9.11.4-16.P2.el7 +3

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2020:1845
Red Hat Enterprise Linux BaseOS (v. 8)Fixed RHSA-2020:1845
Red Hat Enterprise Linux Client (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux Client Optional (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux ComputeNode (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux ComputeNode Optional (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux Server (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux Server Optional (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux Workstation (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux Workstation Optional (v. 7)Fixed RHSA-2020:1061
Not affected: 2 products
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-6477
  2. 2026-10-03 Alias added: GHSA-6q2x-892r-7qm4

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources