Improper access control in GE Communicator
Priority LOW 34CWE-284Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-284.
Summary
GE Communicator, all versions prior to 4.0.517, allows a non-administrative user to replace the uninstaller with a malicious version, which could allow an attacker to gain administrator privileges to the system.
Why it matters now
EPSS 0.00342 27th percentileScored 2026-11-07
Fix Fixed GE Communicator: 4.0.517
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | GE Communicator | before 4.0.517 | 4.0.517 | Patch available | CNA |
- GE Communicator Vendor— Affected before 4.0.517 Fixed in 4.0.517 Patch available CNA
Remediation
- Fix · CNA GE Communicator Fixed in 4.0.517
Timeline
- 2026-10-02 Threatist record created from CVE-2019-6566
- 2026-10-03 Alias added: GHSA-h4x7-v6w2-9mg3
References
More Ge Communicator vulnerabilities
- TI-2019-04602 Hard-coded credentials in GE Communicator CVSS 3.1CRITICAL 9.8
- TI-2019-04600 Uncontrolled search path in GE Communicator CVSS 3.1HIGH 7.8
- TI-2017-05517 Heap-based buffer overflow in GE Communicator CVSS 3.0HIGH 7.6
- TI-2019-04618 Uncontrolled search path in GE Communicator CVSS 3.1HIGH 7.8
- TI-2019-04598 Improper access control in GE Communicator CVSS 3.1MEDIUM 5.6
Sources
- CVE-2019-6566 · CVE Program
- CVE-2019-6566 · NVD
- FIRST EPSS
- GHSA-h4x7-v6w2-9mg3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences