python-gnupg 0.4.3 allows context-dependent attackers to trick gnupg to decrypt other…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
python-gnupg 0.4.3 allows context-dependent attackers to trick gnupg to decrypt other ciphertext than intended. To perform the attack, the passphrase to gnupg must be controlled by the adversary and the ciphertext should be trusted. Related to a "CWE-20: Improper Input Validation" issue affecting the affect functionality component.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | python-gnupg (PyPI) | before 0.4.4 | 0.4.4 | Patch available | GHSA-2fch-jvg5-crf6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- python-gnupg (PyPI) Vendor— Affected before 0.4.4 Fixed in 0.4.4 Patch available GHSA-2fch-jvg5-crf6
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python:python-gnupg:0.4.3:*:*:*:*:*:*:* | 0.4.3 | Vulnerable | python-pillow |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:* | 15.0 | Vulnerable | openSUSE |
| cpe:2.3:a:suse:backports:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise:15.0:*:*:*:*:*:*:* | 15.0 | Running on | SUSE |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.10:*:*:*:*:*:*:* | 18.10 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:* | 19.04 | Vulnerable | Canonical |
- cpe:2.3:a:python:python-gnupg:0.4.3:*:*:*:*:*:*:* Versions 0.4.3 Vulnerable ·python-pillow
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:* Versions 15.0 Vulnerable ·openSUSE
- cpe:2.3:a:suse:backports:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise:15.0:*:*:*:*:*:*:* Versions 15.0 Running on ·SUSE
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.10:*:*:*:*:*:*:* Versions 18.10 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:* Versions 19.04 Vulnerable ·Canonical
Remediation
- Fix · GHSA-2fch-jvg5-crf6 python-gnupg (PyPI) Fixed in 0.4.4 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Update Infrastructure 3 for Cloud Providers | Affected | No fix planned: Will not fix |
Not affected: 1 product
- Red Hat Satellite 6
Timeline
- 2026-10-02 Threatist record created from CVE-2019-6690
- 2026-10-03 Alias added: GHSA-2fch-jvg5-crf6
- 2026-10-16 EPSS moved to the 95th–99th percentile
References
Advisory 14
- http://packetstormsecurity.com/files/151341/Python-GnuPG-0.4.3-Improper-Input-Validation.html
- https://pypi.org/project/python-gnupg/#history
- SU-2019:0143-1
- SUSE-SU-2019:0239-1
- [SECURITY] [DLA 1675-1] 20190214 python-gnupg security update
- 20190125 CVE-2019-6690: Improper Input Validation in python-gnupg
- https://blog.hackeriet.no/cve-2019-6690-python-gnupg-vulnerability/
- USN-3964-1
- FEDORA-2019-06f5bbdaf5
- FEDORA-2020-17fb3273b2
- FEDORA-2020-e67d007a67
- [debian-lts-announce] 20211228 [SECURITY] [DLA 2862-1] python-gnupg security update
- https://nvd.nist.gov/vuln/detail/CVE-2019-6690
- https://github.com/advisories/GHSA-2fch-jvg5-crf6
Other 6
- https://blog.hackeriet.no/cve-2019-6690-python-gnupg-vulnerability
- https://lists.fedoraproject.org/archives/list/[email protected]/message/3WMV6XNPPL3VB3RQRFFOBCJ3AGWC4K47
- https://lists.fedoraproject.org/archives/list/[email protected]/message/W6KYZMN2PWXY4ENZVJUVTGFBVYEVY7II
- https://lists.fedoraproject.org/archives/list/[email protected]/message/X4VFRUG56542LTYK4444TPJBGR57MT25
- https://usn.ubuntu.com/3964-1
- https://web.archive.org/web/20200227091727/http://www.securityfocus.com/bid/106756
Sources
- CVE-2019-6690 · CVE Program
- CVE-2019-6690 · NVD
- FIRST EPSS
- GHSA-2fch-jvg5-crf6 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-6690 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences