CRLF Injection in pypiserver 1.2.5 and below allows attackers to set arbitrary HTTP…
Priority LOW 34CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
CRLF Injection in pypiserver 1.2.5 and below allows attackers to set arbitrary HTTP headers and possibly conduct XSS attacks via a %0d%0a in a URI.
Why it matters now
EPSS 0.03802 90th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed pypiserver (PyPI): 1.2.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pypiserver (PyPI) | before 1.2.6 | 1.2.6 | Patch available | GHSA-mh24-7wvg-v88g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pypiserver (PyPI) Vendor— Affected before 1.2.6 Fixed in 1.2.6 Patch available GHSA-mh24-7wvg-v88g
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python:pypiserver:*:*:*:*:*:*:*:* | up to 1.2.5 | Vulnerable | python-pillow |
- cpe:2.3:a:python:pypiserver:*:*:*:*:*:*:*:* Versions up to 1.2.5 Vulnerable ·python-pillow
Remediation
- Fix · GHSA-mh24-7wvg-v88g pypiserver (PyPI) Fixed in 1.2.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-6802
- 2026-10-03 Alias added: GHSA-mh24-7wvg-v88g
- 2026-10-31 EPSS moved to the 90th–95th percentile
References
Sources
- CVE-2019-6802 · CVE Program
- CVE-2019-6802 · NVD
- FIRST EPSS
- GHSA-mh24-7wvg-v88g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences