SQLAlchemy through 1.2.17 and 1.3.x through 1.3.0b2 allows SQL Injection via the order_by parameter.
Priority MEDIUM 48CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 fixed, 10 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-89.
Summary
SQLAlchemy through 1.2.17 and 1.3.x through 1.3.0b2 allows SQL Injection via the order_by parameter.
Why it matters now
EPSS 0.03496 89th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial SQLAlchemy (PyPI): 1.3.0b3Red Hat: 2 advisoriesRed Hat: 1 fixed, 10 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | SQLAlchemy (PyPI) | before 1.3.0b3 | 1.3.0b3 | Patch available | GHSA-887w-45rq-vxgf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- SQLAlchemy (PyPI) Vendor— Affected before 1.3.0b3 Fixed in 1.3.0b3 Patch available GHSA-887w-45rq-vxgf
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sqlalchemy:sqlalchemy:*:*:*:*:*:*:*:* | up to 1.2.17 | Vulnerable | sqlalchemy |
| cpe:2.3:a:sqlalchemy:sqlalchemy:1.3.0:beta1:*:*:*:*:*:* | 1.3.0 beta1 | Vulnerable | sqlalchemy |
| cpe:2.3:a:sqlalchemy:sqlalchemy:1.3.0:beta2:*:*:*:*:*:* | 1.3.0 beta2 | Vulnerable | sqlalchemy |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:a:opensuse:backports_sle:15.0:-:*:*:*:*:*:* | 15.0 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:* | 15.0 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
| cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:-:*:*:* | 8.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_eus:8.1:*:*:*:*:*:*:* | 8.1 | Vulnerable | Red Hat |
- cpe:2.3:a:sqlalchemy:sqlalchemy:*:*:*:*:*:*:*:* Versions up to 1.2.17 Vulnerable ·sqlalchemy
- cpe:2.3:a:sqlalchemy:sqlalchemy:1.3.0:beta1:*:*:*:*:*:* Versions 1.3.0 beta1 Vulnerable ·sqlalchemy
- cpe:2.3:a:sqlalchemy:sqlalchemy:1.3.0:beta2:*:*:*:*:*:* Versions 1.3.0 beta2 Vulnerable ·sqlalchemy
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:a:opensuse:backports_sle:15.0:-:*:*:*:*:*:* Versions 15.0 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:* Versions 15.0 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
- cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:-:*:*:* Versions 8.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_eus:8.1:*:*:*:*:*:*:* Versions 8.1 Vulnerable ·Red Hat
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:redhat:enterprise_linux_eus:8.2:*:*:*:*:*:*:* | 8.2 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_eus:8.4:*:*:*:*:*:*:* | 8.4 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_aus:8.2:*:*:*:*:*:*:* | 8.2 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_aus:8.4:*:*:*:*:*:*:* | 8.4 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_tus:8.2:*:*:*:*:*:*:* | 8.2 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_tus:8.4:*:*:*:*:*:*:* | 8.4 | Vulnerable | Red Hat |
| cpe:2.3:a:oracle:communications_operations_monitor:4.2:*:*:*:*:*:*:* | 4.2 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:communications_operations_monitor:4.3:*:*:*:*:*:*:* | 4.3 | Vulnerable | Oracle |
- cpe:2.3:o:redhat:enterprise_linux_eus:8.2:*:*:*:*:*:*:* Versions 8.2 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_eus:8.4:*:*:*:*:*:*:* Versions 8.4 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_aus:8.2:*:*:*:*:*:*:* Versions 8.2 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_aus:8.4:*:*:*:*:*:*:* Versions 8.4 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_tus:8.2:*:*:*:*:*:*:* Versions 8.2 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_tus:8.4:*:*:*:*:*:*:* Versions 8.4 Vulnerable ·Red Hat
- cpe:2.3:a:oracle:communications_operations_monitor:4.2:*:*:*:*:*:*:* Versions 4.2 Vulnerable ·Oracle
- cpe:2.3:a:oracle:communications_operations_monitor:4.3:*:*:*:*:*:*:* Versions 4.3 Vulnerable ·Oracle
Remediation
- Fix · GHSA-887w-45rq-vxgf SQLAlchemy (PyPI) Fixed in 1.3.0b3 Advisory →
Red Hat 2 advisories
- RHSA-2019:0981 Released 2019-05-07 · Red Hat rating Importantpython27:2.7 security update
- Red Hat Enterprise Linux AppStream (v. 8) Cython-0.28.1-7.module+el8.0.0+2961+596d0223.src::python27:2.7, PyYAML-3.12-16.module+el8.0.0+2961+596d0223.src::python27:2.7, babel-2.5.1-9.module+el8.0.0+2961+596d0223.noarch::python27:2.7 +47
- RHSA-2019:0984 Released 2019-05-07 · Red Hat rating Moderatepython36:3.6 security update
- Red Hat Enterprise Linux AppStream (v. 8) python-PyMySQL-0.8.0-10.module+el8.0.0+2966+d39a1df3.src::python36:3.6, python-docs-3.6.7-2.module+el8.0.0+2966+d39a1df3.src::python36:3.6, python-docutils-0.14-12.module+el8.0.0+2966+d39a1df3.src::python36:3.6 +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 2 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix yet |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix yet |
| Red Hat OpenStack Platform 14 (Rocky) | Affected | No fix yet |
| Red Hat OpenStack Platform 15 (Stein) | Affected | No fix yet |
| Red Hat OpenStack Platform 8 (Liberty) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 9 (Mitaka) | Affected | No fix planned: Will not fix |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2019:0981, RHSA-2019:0984 |
Timeline
- 2026-10-02 Threatist record created from CVE-2019-7164
- 2026-10-03 Alias added: GHSA-887w-45rq-vxgf
References
Advisory 9
- [debian-lts-announce] 20190318 [SECURITY] [DLA 1718-1] sqlalchemy security update
- RHSA-2019:0984
- RHSA-2019:0981
- openSUSE-SU-2019:2039
- openSUSE-SU-2019:2064
- openSUSE-SU-2019:2078
- [debian-lts-announce] 20211106 [SECURITY] [DLA 2811-1] sqlalchemy security update
- https://nvd.nist.gov/vuln/detail/CVE-2019-7164
- https://github.com/advisories/GHSA-887w-45rq-vxgf
Sources
- CVE-2019-7164 · CVE Program
- CVE-2019-7164 · NVD
- FIRST EPSS
- GHSA-887w-45rq-vxgf · GitHub Advisory Database · CC BY 4.0
- CVE-2019-7164 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences