Unrestricted file upload in Adobe Magento 1 & 2
Priority LOW 35CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-434.
Summary
A remote code execution vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to import features can execute arbitrary code via crafted configuration archive file upload.
Why it matters now
EPSS 0.01852 79th percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 1.9.4.3, 2.2.10, 2.3.2-p2magento/project-community-edition (Packagist): 1.9.4.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Magento 1 & 2 | Magento Open Source prior to 1.9.4.3; and Magento Commerce prior to 1.14.4.3; Magento 2.2 prior to 2.2.10; Magento 2.3 prior to 2.3.3 or 2.3.2-p1 | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | before 1.9.4.3 | 1.9.4.3 | Patch available | GHSA-crv7-r357-gw3w |
| — | magento/community-edition (Packagist) | 2.2.0 to before 2.2.10 | 2.2.10 | Patch available | GHSA-crv7-r357-gw3w |
| — | magento/community-edition (Packagist) | 2.3.0 to before 2.3.2-p2 | 2.3.2-p2 | Patch available | GHSA-crv7-r357-gw3w |
| — | magento/project-community-edition (Packagist) | before 1.9.4.3 | 1.9.4.3 | Patch available | GHSA-crv7-r357-gw3w |
- Magento 1 & 2 VendorAdobe Affected Magento Open Source prior to 1.9.4.3; and Magento Commerce prior to 1.14.4.3; Magento 2.2 prior to 2.2.10; Magento 2.3 prior to 2.3.3 or 2.3.2-p1 Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected before 1.9.4.3 Fixed in 1.9.4.3 Patch available GHSA-crv7-r357-gw3w
- magento/community-edition (Packagist) Vendor— Affected 2.2.0 to before 2.2.10 Fixed in 2.2.10 Patch available GHSA-crv7-r357-gw3w
- magento/community-edition (Packagist) Vendor— Affected 2.3.0 to before 2.3.2-p2 Fixed in 2.3.2-p2 Patch available GHSA-crv7-r357-gw3w
- magento/project-community-edition (Packagist) Vendor— Affected before 1.9.4.3 Fixed in 1.9.4.3 Patch available GHSA-crv7-r357-gw3w
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | before 1.9.4.3 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* | before 1.14.4.3; 2.2.0 to before 2.2.10 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | 2.2.0 to before 2.2.10 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* | 2.3.0 – 2.3.2 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | 2.3.0 – 2.3.2 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.2:-:*:*:commerce:*:*:* | 2.3.2 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.2:-:*:*:open_source:*:*:* | 2.3.2 | Vulnerable | Magento |
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions before 1.9.4.3 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions before 1.14.4.3; 2.2.0 to before 2.2.10 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.2.0 to before 2.2.10 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.3.0 – 2.3.2 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.3.0 – 2.3.2 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.2:-:*:*:commerce:*:*:* Versions 2.3.2 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.2:-:*:*:open_source:*:*:* Versions 2.3.2 Vulnerable ·Magento
Remediation
- Fix · GHSA-crv7-r357-gw3w magento/community-edition (Packagist) Fixed in 1.9.4.3 Advisory →
- Fix · GHSA-crv7-r357-gw3w magento/community-edition (Packagist) Fixed in 2.2.10 Advisory →
- Fix · GHSA-crv7-r357-gw3w magento/community-edition (Packagist) Fixed in 2.3.2-p2 Advisory →
- Fix · GHSA-crv7-r357-gw3w magento/project-community-edition (Packagist) Fixed in 1.9.4.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-8114
- 2026-10-03 Alias added: GHSA-crv7-r357-gw3w
References
Other 7
- https://devdocs-openmage.org/guides/m1x//ce19-ee114/ee1.14_release-notes.html#ee114-11443
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ce/CVE-2019-8114.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ee/CVE-2019-8114.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8114.yaml
- https://github.com/magento/magento2
- https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
- https://web.archive.org/web/20211209030216/https://magento.com/security/patches/supee-11219
More Adobe vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2026-35688 ColdFusion | Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22) KEVCVSS 3.1CRITICAL 10.0
- TI-2025-34084 Adobe Experience Manager | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2023-19615 Analysis CVE-2023-29300 Bypass: Adobe ColdFusion Pre-Auth RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2023-13696 Adobe ColdFusion Deserialization of Untrusted Data Arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-8114 · CVE Program
- CVE-2019-8114 · NVD
- FIRST EPSS
- GHSA-crv7-r357-gw3w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences