Insufficient verification of data authenticity in Adobe Magento 2
Priority LOW 24CWE-345Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-345.
Summary
An insufficient logging and monitoring vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. Failure to track admin actions related to design configuration could lead to repudiation attacks.
Why it matters now
EPSS 0.00964 61st percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.1.19, 2.2.10, 2.3.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Magento 2 | Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p2 | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | 2.1.0 to before 2.1.19 | 2.1.19 | Patch available | GHSA-x5q5-6wvf-2fpq |
| — | magento/community-edition (Packagist) | 2.2.0 to before 2.2.10 | 2.2.10 | Patch available | GHSA-x5q5-6wvf-2fpq |
| — | magento/community-edition (Packagist) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-x5q5-6wvf-2fpq |
- Magento 2 VendorAdobe Affected Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p2 Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected 2.1.0 to before 2.1.19 Fixed in 2.1.19 Patch available GHSA-x5q5-6wvf-2fpq
- magento/community-edition (Packagist) Vendor— Affected 2.2.0 to before 2.2.10 Fixed in 2.2.10 Patch available GHSA-x5q5-6wvf-2fpq
- magento/community-edition (Packagist) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-x5q5-6wvf-2fpq
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* | 2.1.0 to before 2.1.19 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | 2.1.0 to before 2.1.19 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* | 2.2.0 to before 2.2.10 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | 2.2.0 to before 2.2.10 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* | 2.3.0 to before 2.3.2 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | 2.3.0 to before 2.3.2 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.2:-:*:*:commerce:*:*:* | 2.3.2 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.2:-:*:*:open_source:*:*:* | 2.3.2 | Vulnerable | Magento |
- cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.1.0 to before 2.1.19 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.1.0 to before 2.1.19 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.2.0 to before 2.2.10 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.2.0 to before 2.2.10 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.3.0 to before 2.3.2 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.3.0 to before 2.3.2 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.2:-:*:*:commerce:*:*:* Versions 2.3.2 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.2:-:*:*:open_source:*:*:* Versions 2.3.2 Vulnerable ·Magento
Remediation
- Fix · GHSA-x5q5-6wvf-2fpq magento/community-edition (Packagist) Fixed in 2.1.19 Advisory →
- Fix · GHSA-x5q5-6wvf-2fpq magento/community-edition (Packagist) Fixed in 2.2.10 Advisory →
- Fix · GHSA-x5q5-6wvf-2fpq magento/community-edition (Packagist) Fixed in 2.3.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-8124
- 2026-10-03 Alias added: GHSA-x5q5-6wvf-2fpq
References
Advisory 2
More Adobe vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2026-35688 ColdFusion | Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22) KEVCVSS 3.1CRITICAL 10.0
- TI-2025-34084 Adobe Experience Manager | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2023-19615 Analysis CVE-2023-29300 Bypass: Adobe ColdFusion Pre-Auth RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2023-13696 Adobe ColdFusion Deserialization of Untrusted Data Arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-8124 · CVE Program
- CVE-2019-8124 · NVD
- FIRST EPSS
- GHSA-x5q5-6wvf-2fpq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences