SQL injection in Adobe Magento 2
Priority MEDIUM 40CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. A user with store manipulation privileges can execute arbitrary SQL queries by getting access to the database connection through group instance in email templates.
Why it matters now
EPSS 0.01002 63rd percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.2.10, 2.3.2-p1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Magento 2 | Magento 2.2 prior to 2.2.10; Magento 2.3 prior to 2.3.3 or 2.3.2-p1 | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | 2.2.0 to before 2.2.10 | 2.2.10 | Patch available | GHSA-x42g-82pp-4v6g |
| — | magento/community-edition (Packagist) | 2.3.0 to before 2.3.2-p1 | 2.3.2-p1 | Patch available | GHSA-x42g-82pp-4v6g |
- Magento 2 VendorAdobe Affected Magento 2.2 prior to 2.2.10; Magento 2.3 prior to 2.3.3 or 2.3.2-p1 Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected 2.2.0 to before 2.2.10 Fixed in 2.2.10 Patch available GHSA-x42g-82pp-4v6g
- magento/community-edition (Packagist) Vendor— Affected 2.3.0 to before 2.3.2-p1 Fixed in 2.3.2-p1 Patch available GHSA-x42g-82pp-4v6g
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* | 2.2.0 to before 2.2.10 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | 2.2.0 to before 2.2.10 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* | 2.3.0 to before 2.3.2 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | 2.3.0 to before 2.3.2 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.2:-:*:*:commerce:*:*:* | 2.3.2 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.2:-:*:*:open_source:*:*:* | 2.3.2 | Vulnerable | Magento |
- cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.2.0 to before 2.2.10 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.2.0 to before 2.2.10 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.3.0 to before 2.3.2 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.3.0 to before 2.3.2 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.2:-:*:*:commerce:*:*:* Versions 2.3.2 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.2:-:*:*:open_source:*:*:* Versions 2.3.2 Vulnerable ·Magento
Remediation
- Fix · GHSA-x42g-82pp-4v6g magento/community-edition (Packagist) Fixed in 2.2.10 Advisory →
- Fix · GHSA-x42g-82pp-4v6g magento/community-edition (Packagist) Fixed in 2.3.2-p1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-8130
- 2026-10-03 Alias added: GHSA-x42g-82pp-4v6g
References
Advisory 2
More Adobe vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2026-35688 ColdFusion | Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22) KEVCVSS 3.1CRITICAL 10.0
- TI-2025-34084 Adobe Experience Manager | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2023-19615 Analysis CVE-2023-29300 Bypass: Adobe ColdFusion Pre-Auth RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2023-13696 Adobe ColdFusion Deserialization of Untrusted Data Arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-8130 · CVE Program
- CVE-2019-8130 · NVD
- FIRST EPSS
- GHSA-x42g-82pp-4v6g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences