Read the docs
TI-2019-05829 Aliases CVE-2019-8156GHSA-775w-gx3f-4j4f

Server-side request forgery in Adobe Magento 2

Priority LOW 35CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

A server-side request forgery (SSRF) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to modify store configurations can manipulate the connector api endpoint to enable remote code execution.

Why it matters now

EPSS 0.01714 77th percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.2.10, 2.3.2-p2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
AdobeMagento 2Magento 2.2 prior to 2.2.10; Magento 2.3 prior to 2.3.3 or 2.3.2-p1—No fix listedCNA
—magento/community-edition (Packagist)2.2.0 to before 2.2.102.2.10Patch availableGHSA-775w-gx3f-4j4f
—magento/community-edition (Packagist)2.3.0 to before 2.3.2-p22.3.2-p2Patch availableGHSA-775w-gx3f-4j4f
  • Magento 2 VendorAdobe Affected Magento 2.2 prior to 2.2.10; Magento 2.3 prior to 2.3.3 or 2.3.2-p1 Fixed in — No fix listed CNA
  • magento/community-edition (Packagist) Vendor— Affected 2.2.0 to before 2.2.10 Fixed in 2.2.10 Patch available GHSA-775w-gx3f-4j4f
  • magento/community-edition (Packagist) Vendor— Affected 2.3.0 to before 2.3.2-p2 Fixed in 2.3.2-p2 Patch available GHSA-775w-gx3f-4j4f

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:*2.2.0 to before 2.2.10VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*2.2.0 to before 2.2.10VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:*2.3.0 to before 2.3.2VulnerableMagento
cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*2.3.0 to before 2.3.2VulnerableMagento
cpe:2.3:a:magento:magento:2.3.2:-:*:*:commerce:*:*:*2.3.2VulnerableMagento
cpe:2.3:a:magento:magento:2.3.2:-:*:*:open_source:*:*:*2.3.2VulnerableMagento
  • cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.2.0 to before 2.2.10 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.2.0 to before 2.2.10 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.3.0 to before 2.3.2 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.3.0 to before 2.3.2 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.3.2:-:*:*:commerce:*:*:* Versions 2.3.2 Vulnerable ·Magento
  • cpe:2.3:a:magento:magento:2.3.2:-:*:*:open_source:*:*:* Versions 2.3.2 Vulnerable ·Magento

Remediation

  • Fix · GHSA-775w-gx3f-4j4f magento/community-edition (Packagist) Fixed in 2.2.10 Advisory →
  • Fix · GHSA-775w-gx3f-4j4f magento/community-edition (Packagist) Fixed in 2.3.2-p2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-8156
  2. 2026-10-03 Alias added: GHSA-775w-gx3f-4j4f

References

  • TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-35688 ColdFusion | Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22) KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-34084 Adobe Experience Manager | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-19615 Analysis CVE-2023-29300 Bypass: Adobe ColdFusion Pre-Auth RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-13696 Adobe ColdFusion Deserialization of Untrusted Data Arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
See all 8046 →

Sources