Improper input validation in Apple macOS
Priority LOW 25CWE-20Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Multiple memory corruption issues were addressed with improved input validation. This issue is fixed in macOS Mojave 10.14.4. Processing malicious data may lead to unexpected application termination.
Why it matters now
EPSS 0.00332 26th percentileScored 2026-11-07
Fix Fixed macOS (Apple): macOS Mojave 10.14.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA macOS (Apple) Fixed in macOS Mojave 10.14.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apple macOS macOS Mojave 10.14.4
33 records Highest priority Priority CRITICAL 1 CRITICAL, 4 MEDIUM, 28 LOW
Other records, highest priority first
- TI-2019-06104 Use after free in Apple macOSPriority CRITICAL 93
- TI-2019-06141 Race condition in Apple iOSPriority MEDIUM 46
- TI-2019-06105 Buffer overflow in Apple iOSPriority MEDIUM 45
Timeline
- 2026-10-02 Threatist record created from CVE-2019-8507
- 2026-10-03 Alias added: GHSA-rxgh-9c22-r8rj
References
Advisory 1
More Apple Mac Os X vulnerabilities
- TI-2021-01573 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2021-01572 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02117 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2019-8507 · CVE Program
- CVE-2019-8507 · NVD
- FIRST EPSS
- GHSA-rxgh-9c22-r8rj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences