Improper authentication in Apple macOS
Priority MEDIUM 40CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-287.
Summary
An authentication issue was addressed with improved state management. This issue is fixed in macOS Mojave 10.14.5. A user may be unexpectedly logged in to another user’s account.
Why it matters now
EPSS 0.00986 62nd percentileScored 2026-11-07
Fix Fixed macOS (Apple): macOS Mojave 10.14.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apple | macOS | before macOS Mojave 10.14.5 | macOS Mojave 10.14.5 | Patch available | CNA |
- macOS VendorApple Affected before macOS Mojave 10.14.5 Fixed in macOS Mojave 10.14.5 Patch available CNA
CPE configurations NVD · 16
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* | before 10.12.6; before 10.14.5; 10.13 to before 10.13.6 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.12.6:-:*:*:*:*:*:* | 10.12.6 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2017-001:*:*:*:*:*:* | 10.12.6 security_update_2017-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2018-001:*:*:*:*:*:* | 10.12.6 security_update_2018-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2018-002:*:*:*:*:*:* | 10.12.6 security_update_2018-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2018-003:*:*:*:*:*:* | 10.12.6 security_update_2018-003 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2018-004:*:*:*:*:*:* | 10.12.6 security_update_2018-004 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2018-005:*:*:*:*:*:* | 10.12.6 security_update_2018-005 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2018-006:*:*:*:*:*:* | 10.12.6 security_update_2018-006 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2019-001:*:*:*:*:*:* | 10.12.6 security_update_2019-001 | Vulnerable | Apple |
- cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* Versions before 10.12.6; before 10.14.5; 10.13 to before 10.13.6 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.12.6:-:*:*:*:*:*:* Versions 10.12.6 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2017-001:*:*:*:*:*:* Versions 10.12.6 security_update_2017-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2018-001:*:*:*:*:*:* Versions 10.12.6 security_update_2018-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2018-002:*:*:*:*:*:* Versions 10.12.6 security_update_2018-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2018-003:*:*:*:*:*:* Versions 10.12.6 security_update_2018-003 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2018-004:*:*:*:*:*:* Versions 10.12.6 security_update_2018-004 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2018-005:*:*:*:*:*:* Versions 10.12.6 security_update_2018-005 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2018-006:*:*:*:*:*:* Versions 10.12.6 security_update_2018-006 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2019-001:*:*:*:*:*:* Versions 10.12.6 security_update_2019-001 Vulnerable ·Apple
Show 6 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2019-002:*:*:*:*:*:* | 10.12.6 security_update_2019-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:-:*:*:*:*:*:* | 10.13.6 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2018-002:*:*:*:*:*:* | 10.13.6 security_update_2018-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2018-003:*:*:*:*:*:* | 10.13.6 security_update_2018-003 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-001:*:*:*:*:*:* | 10.13.6 security_update_2019-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-002:*:*:*:*:*:* | 10.13.6 security_update_2019-002 | Vulnerable | Apple |
- cpe:2.3:o:apple:mac_os_x:10.12.6:security_update_2019-002:*:*:*:*:*:* Versions 10.12.6 security_update_2019-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:-:*:*:*:*:*:* Versions 10.13.6 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2018-002:*:*:*:*:*:* Versions 10.13.6 security_update_2018-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2018-003:*:*:*:*:*:* Versions 10.13.6 security_update_2018-003 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-001:*:*:*:*:*:* Versions 10.13.6 security_update_2019-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.13.6:security_update_2019-002:*:*:*:*:*:* Versions 10.13.6 security_update_2019-002 Vulnerable ·Apple
Remediation
- Fix · CNA macOS (Apple) Fixed in macOS Mojave 10.14.5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apple macOS macOS Mojave 10.14.5
41 records Highest priority Priority CRITICAL 1 CRITICAL, 23 MEDIUM, 17 LOW
Other records, highest priority first
- TI-2019-06181 Use after free in Apple iOSPriority CRITICAL 93
- TI-2019-06176 Out-of-bounds write in Apple iOSPriority MEDIUM 61
- TI-2019-06197 Out-of-bounds write in Apple iOSPriority MEDIUM 49
Timeline
- 2026-10-02 Threatist record created from CVE-2019-8634
- 2026-10-03 Alias added: GHSA-fhpw-7642-ff4w
References
Advisory 1
More Apple Mac Os X vulnerabilities
- TI-2021-01573 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2021-01572 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02117 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2019-8634 · CVE Program
- CVE-2019-8634 · NVD
- FIRST EPSS
- GHSA-fhpw-7642-ff4w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences