Improper input validation in Apple Xcode
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Multiple issues in ld64 in the Xcode toolchains were addressed by updating to version ld64-507.4. This issue is fixed in Xcode 11.0. Compiling code without proper input validation could lead to arbitrary code execution with user privilege.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Xcode (Apple) Fixed in Xcode 11.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apple Xcode Xcode 11.0
6 records Highest priority Priority MEDIUM 4 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2019-06288 Improper input validation in Apple XcodePriority MEDIUM 42
- TI-2019-06287 Improper input validation in Apple XcodePriority MEDIUM 42
- TI-2019-06285 Improper input validation in Apple XcodePriority MEDIUM 42
Timeline
- 2026-10-02 Threatist record created from CVE-2019-8722
- 2026-10-03 Alias added: GHSA-9jhp-mffm-h2q2
References
Advisory 1
More Apple Xcode vulnerabilities
- TI-2021-19919 Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints KEVCVSS 3.1CRITICAL 10.0
- TI-2025-30709 Git allows arbitrary code execution through broken config quoting KEVCVSS 3.1HIGH 8.1
- TI-2004-02557 distcc 2.x, as used in XCode 1.5 and others, when not configured to restrict access to… CVSS 2.0HIGH 9.3
- TI-2014-07619 Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x… CVSS 3.1CRITICAL 9.8
- TI-2021-04400 malicious repositories can execute remote code while cloning CVSS 3.1HIGH 8.0
- TI-2016-00666 The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to… CVSS 3.1HIGH 7.5
Sources
- CVE-2019-8722 · CVE Program
- CVE-2019-8722 · NVD
- FIRST EPSS
- GHSA-9jhp-mffm-h2q2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences