Apple macOS: A malicious application may be able to access recent documents
Priority LOW 27Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The issue was addressed with improved permissions logic. This issue is fixed in macOS Catalina 10.15. A malicious application may be able to access recent documents.
Why it matters now
EPSS 0.00891 59th percentileScored 2026-11-07
Fix Fixed macOS (Apple): macOS Catalina 10.15
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA macOS (Apple) Fixed in macOS Catalina 10.15
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apple macOS macOS Catalina 10.15
12 records Highest priority Priority MEDIUM 2 MEDIUM, 10 LOW
Other records, highest priority first
- TI-2019-06308 Memory corruption in Apple macOSPriority MEDIUM 42
- TI-2019-06343 Out-of-bounds write in Apple macOSPriority MEDIUM 40
- TI-2019-06281 Out-of-bounds write in Apple macOSPriority LOW 37
Timeline
- 2026-10-02 Threatist record created from CVE-2019-8770
- 2026-10-03 Alias added: GHSA-mq38-2wxp-9cm4
References
Advisory 1
More Apple Mac Os X vulnerabilities
- TI-2021-01573 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2021-01572 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02117 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2019-8770 · CVE Program
- CVE-2019-8770 · NVD
- FIRST EPSS
- GHSA-mq38-2wxp-9cm4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences