In irisnet-crypto before 1.1.7 for IRISnet, the util/utils.js file allows code execution because of unsafe eval usage.
Priority MEDIUM 47CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
In irisnet-crypto before 1.1.7 for IRISnet, the util/utils.js file allows code execution because of unsafe eval usage.
Why it matters now
EPSS 0.02332 83rd percentileScored 2026-11-07
Fix Fixed irisnet-crypto (npm): 1.1.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | irisnet-crypto (npm) | before 1.1.7 | 1.1.7 | Patch available | GHSA-5fh8-x9xc-hxmc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- irisnet-crypto (npm) Vendor— Affected before 1.1.7 Fixed in 1.1.7 Patch available GHSA-5fh8-x9xc-hxmc
Remediation
- Fix · GHSA-5fh8-x9xc-hxmc irisnet-crypto (npm) Fixed in 1.1.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-9115
- 2026-10-03 Alias added: GHSA-5fh8-x9xc-hxmc
References
Sources
- CVE-2019-9115 · CVE Program
- CVE-2019-9115 · NVD
- FIRST EPSS
- GHSA-5fh8-x9xc-hxmc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences