elFinder before 2.1.48 has a command injection vulnerability in the PHP connector.
Priority CRITICAL 86CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
elFinder before 2.1.48 has a command injection vulnerability in the PHP connector.
Why it matters now
EPSS 0.9673 99th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by the CNA and NVD
Fix Fixed studio-42/elfinder (Packagist): 2.1.48
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | studio-42/elfinder (Packagist) | before 2.1.48 | 2.1.48 | Patch available | GHSA-4223-qj94-7x9p |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- studio-42/elfinder (Packagist) Vendor— Affected before 2.1.48 Fixed in 2.1.48 Patch available GHSA-4223-qj94-7x9p
Remediation
- Fix · GHSA-4223-qj94-7x9p studio-42/elfinder (Packagist) Fixed in 2.1.48 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-9194
- 2026-10-03 Alias added: GHSA-4223-qj94-7x9p
References
Advisory 3
Other 5
- https://github.com/Studio-42/elFinder/commit/374c88d7030eb92749267e17a4af21cc7520efa5
- https://github.com/FriendsOfPHP/security-advisories/blob/master/studio-42/elfinder/CVE-2019-9194.yaml
- https://github.com/Studio-42/elFinder
- https://www.exploit-db.com/exploits/46481
- https://www.exploit-db.com/exploits/46539
More Std42 Elfinder vulnerabilities
- TI-2023-28504 Studio-42 eLfinder 2.1.62 is vulnerable to Remote Code Execution (RCE) as there is no… CVSS 3.1CRITICAL 9.8
- TI-2021-12350 Multiple vulnerabilities leading to RCE CVSS 3.1CRITICAL 9.8
- TI-2022-10186 connector.minimal.php in std42 elFinder through 2.1.60 is affected by path traversal. CVSS 3.1CRITICAL 9.1
- TI-2021-19360 A File Upload vulnerability exists in Studio-42 elFinder 2.0.4 to 2.1.59 via… CVSS 3.1CRITICAL 9.8
- TI-2022-10265 In Studio-42 elFinder 2.1.60, there is a vulnerability that causes remote code execution… CVSS 3.1CRITICAL 9.8
- TI-2023-17916 _joinPath in elFinderVolumeLocalFileSystem.class.php in elFinder before 2.1.62 allows… CVSS 3.1MEDIUM 6.5
Sources
- CVE-2019-9194 · CVE Program
- CVE-2019-9194 · NVD
- FIRST EPSS
- GHSA-4223-qj94-7x9p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences