Path traversal in podman
Priority LOW 32CWE-22Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
A path traversal vulnerability has been discovered in podman before version 1.4.0 in the way it handles symlinks inside containers. An attacker who has compromised an existing container can cause arbitrary files on the host filesystem to be read/written when an administrator tries to copy a file from/to the container.
Why it matters now
EPSS 0.00468 40th percentileScored 2026-11-07
Fix Fixed github.com/containers/podman (Go): 1.4.0Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Podman | podman | fixed in 1.4.0 | — | No fix listed | CNA |
| — | github.com/containers/podman (Go) | before 1.4.0 | 1.4.0 | Patch available | GHSA-rh5f-2w6r-q7vj |
- podman VendorPodman Affected fixed in 1.4.0 Fixed in — No fix listed CNA
- github.com/containers/podman (Go) Vendor— Affected before 1.4.0 Fixed in 1.4.0 Patch available GHSA-rh5f-2w6r-q7vj
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libpod_project:libpod:*:*:*:*:*:*:*:* | before 1.4.0 | Vulnerable | Libpod Project |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
- cpe:2.3:a:libpod_project:libpod:*:*:*:*:*:*:*:* Versions before 1.4.0 Vulnerable ·Libpod Project
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
Remediation
- Fix · GHSA-rh5f-2w6r-q7vj github.com/containers/podman (Go) Fixed in 1.4.0 Advisory →
Red Hat 1 advisory
- RHSA-2019:1907 Released 2019-07-29 · Red Hat rating Moderatepodman security, bug fix, and enhancement update
- Red Hat Enterprise Linux 7 Extras podman-1.4.4-2.el7, podman-docker-1.4.4-2.el7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 Extras | Fixed | RHSA-2019:1907 |
Not affected: 3 products
- Red Hat Enterprise Linux 8
- Red Hat OpenShift Container Platform 3.11
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10152
- 2026-10-03 Alias added: GHSA-rh5f-2w6r-q7vj
References
Advisory 5
Sources
- CVE-2019-10152 · CVE Program
- CVE-2019-10152 · NVD
- FIRST EPSS
- GHSA-rh5f-2w6r-q7vj · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10152 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences