In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its…
Priority LOW 38CWE-648Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 11 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In ghostscript before version 9.50, the .buildfont1 procedure did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges and access files outside of restricted areas.
Why it matters now
EPSS 0.02295 83rd percentileScored 2026-11-07
Fix Partial ghostscript (ghostscript): 9.50Red Hat: 3 advisoriesRed Hat: 11 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Ghostscript | ghostscript | before 9.50 | 9.50 | Patch available | CNA |
- ghostscript VendorGhostscript Affected before 9.50 Fixed in 9.50 Patch available CNA
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:* | before 9.50 | Vulnerable | Artifex |
| cpe:2.3:a:redhat:3scale_api_management:2.6:*:*:*:*:*:*:* | 2.6 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:5.0:*:*:*:*:*:*:* | 5.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_aus:7.7:*:*:*:*:*:*:* | 7.7 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_eus:7.7:*:*:*:*:*:*:* | 7.7 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server_tus:7.7:*:*:*:*:*:*:* | 7.7 | Vulnerable | Red Hat |
- cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:* Versions before 9.50 Vulnerable ·Artifex
- cpe:2.3:a:redhat:3scale_api_management:2.6:*:*:*:*:*:*:* Versions 2.6 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_aus:7.7:*:*:*:*:*:*:* Versions 7.7 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_eus:7.7:*:*:*:*:*:*:* Versions 7.7 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server_tus:7.7:*:*:*:*:*:*:* Versions 7.7 Vulnerable ·Red Hat
Remediation
- Fix · CNA ghostscript (ghostscript) Fixed in 9.50
Red Hat 3 advisories
- RHSA-2019:2534 Released 2019-08-21 · Red Hat rating ImportantRed Hat 3scale API Management 2.6.0 release and security update
- RHAMP-2.6 3scale-amp26/3scale-operator, 3scale-amp26/apicast-gateway, 3scale-amp26/backend +3
- RHSA-2019:2465 Released 2019-08-12 · Red Hat rating Importantghostscript security update
- Red Hat CodeReady Linux Builder (v. 8) ghostscript-doc-9.25-2.el8_0.2, ghostscript-tools-dvipdf-9.25-2.el8_0.2, ghostscript-tools-fonts-9.25-2.el8_0.2 +3
- Red Hat Enterprise Linux AppStream (v. 8) ghostscript-9.25-2.el8_0.2, libgs-9.25-2.el8_0.2
- RHSA-2019:2462 Released 2019-08-12 · Red Hat rating Importantghostscript security update
- Red Hat Enterprise Linux Client (v. 7) ghostscript-9.25-2.el7_7.1, ghostscript-cups-9.25-2.el7_7.1, libgs-9.25-2.el7_7.1
- Red Hat Enterprise Linux Client Optional (v. 7) ghostscript-doc-9.25-2.el7_7.1, ghostscript-gtk-9.25-2.el7_7.1, libgs-devel-9.25-2.el7_7.1
- Red Hat Enterprise Linux ComputeNode (v. 7) ghostscript-9.25-2.el7_7.1, ghostscript-cups-9.25-2.el7_7.1, libgs-9.25-2.el7_7.1
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) ghostscript-doc-9.25-2.el7_7.1, ghostscript-gtk-9.25-2.el7_7.1, libgs-devel-9.25-2.el7_7.1
- Red Hat Enterprise Linux Server (v. 7) ghostscript-9.25-2.el7_7.1, ghostscript-9.25-2.el7_7.1.ppc, ghostscript-cups-9.25-2.el7_7.1 +2
- Red Hat Enterprise Linux Server Optional (v. 7) ghostscript-doc-9.25-2.el7_7.1, ghostscript-gtk-9.25-2.el7_7.1, libgs-devel-9.25-2.el7_7.1 +1
- Red Hat Enterprise Linux Workstation (v. 7) ghostscript-9.25-2.el7_7.1, ghostscript-cups-9.25-2.el7_7.1, libgs-9.25-2.el7_7.1
- Red Hat Enterprise Linux Workstation Optional (v. 7) ghostscript-doc-9.25-2.el7_7.1, ghostscript-gtk-9.25-2.el7_7.1, libgs-devel-9.25-2.el7_7.1
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| RHAMP-2.6 | Fixed | RHSA-2019:2534 |
| Red Hat CodeReady Linux Builder (v. 8) | Fixed | RHSA-2019:2465 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2019:2465 |
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2019:2462 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2019:2462 |
| Red Hat Enterprise Linux ComputeNode (v. 7) | Fixed | RHSA-2019:2462 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2019:2462 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2019:2462 |
| Red Hat Enterprise Linux Server Optional (v. 7) | Fixed | RHSA-2019:2462 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2019:2462 |
| Red Hat Enterprise Linux Workstation Optional (v. 7) | Fixed | RHSA-2019:2462 |
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10216
- 2026-10-03 Alias added: GHSA-9xw2-pr37-vhp5
References
More Ghostscript vulnerabilities
- TI-2009-04050 Stack-based buffer overflow in the errprintf function in base/gsmisc.c in ghostscript… CVSS 2.0HIGH 9.3
- TI-2009-00183 Heap-based buffer overflow in the big2_decode_symbol_dict function (jbig2_symbol_dict.c)… CVSS 2.0HIGH 9.3
- TI-2009-00560 Multiple integer overflows in icc.c in the International Color Consortium (ICC) Format… CVSS 2.0HIGH 9.3
- TI-2009-00754 Multiple integer overflows in icc.c in the International Color Consortium (ICC) Format… CVSS 2.0HIGH 9.3
- TI-2009-00561 icc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in… CVSS 2.0HIGH 9.3
- TI-2008-00386 Stack-based buffer overflow in the zseticcspace function in zicc.c in Ghostscript 8.61… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2019-10216 · CVE Program
- CVE-2019-10216 · NVD
- FIRST EPSS
- GHSA-9xw2-pr37-vhp5 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10216 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences