Missing authorization in Jenkins Netsparker Cloud Scan Plugin
Priority LOW 32CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
A missing permission check in Jenkins Netsparker Cloud Scan Plugin 1.1.5 and older in the NCScanBuilder.DescriptorImpl#doValidateAPI form validation method allowed attackers with Overall/Read permission to initiate a connection to an attacker-specified server.
Why it matters now
EPSS 0.01508 74th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:netsparker-cloud-scan (Maven): 1.1.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Netsparker Cloud Scan Plugin | 1.1.5 and older | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:netsparker-cloud-scan (Maven) | before 1.1.6 | 1.1.6 | Patch available | GHSA-whcg-2364-672f |
- Jenkins Netsparker Cloud Scan Plugin VendorJenkins Affected 1.1.5 and older Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:netsparker-cloud-scan (Maven) Vendor— Affected before 1.1.6 Fixed in 1.1.6 Patch available GHSA-whcg-2364-672f
Remediation
- Fix · GHSA-whcg-2364-672f org.jenkins-ci.plugins:netsparker-cloud-scan (Maven) Fixed in 1.1.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10290
- 2026-10-03 Alias added: GHSA-whcg-2364-672f
References
More Jenkins Netsparker Cloud Scan vulnerabilities
- TI-2019-07600 Insufficiently protected credentials in Jenkins Netsparker Cloud Scan Plugin CVSS 3.1HIGH 8.8
- TI-2019-07598 Cross-site request forgery in Jenkins Netsparker Cloud Scan Plugin CVSS 3.0MEDIUM 6.5
Sources
- CVE-2019-10290 · CVE Program
- CVE-2019-10290 · NVD
- FIRST EPSS
- GHSA-whcg-2364-672f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences