Cross-site request forgery in Jenkins Static Analysis Utilities Plugin
Priority LOW 31CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A cross-site request forgery vulnerability in Jenkins Static Analysis Utilities Plugin 1.95 and earlier in the DefaultGraphConfigurationView#doSave form handler method allowed attackers to change the per-job default graph configuration for all users.
Why it matters now
EPSS 0.01007 63rd percentileScored 2026-11-07
Fix Fixed org.jvnet.hudson.plugins:analysis-core (Maven): 1.96
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Static Analysis Utilities Plugin | up to 1.95 | — | No fix listed | CNA |
| — | org.jvnet.hudson.plugins:analysis-core (Maven) | before 1.96 | 1.96 | Patch available | GHSA-3v9f-4vff-rx42 |
- Jenkins Static Analysis Utilities Plugin VendorJenkins Affected up to 1.95 Fixed in — No fix listed CNA
- org.jvnet.hudson.plugins:analysis-core (Maven) Vendor— Affected before 1.96 Fixed in 1.96 Patch available GHSA-3v9f-4vff-rx42
Remediation
- Fix · GHSA-3v9f-4vff-rx42 org.jvnet.hudson.plugins:analysis-core (Maven) Fixed in 1.96 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10307
- 2026-10-03 Alias added: GHSA-3v9f-4vff-rx42
References
Advisory 3
More Jenkins Static Analysis Utilities vulnerabilities
- TI-2019-07617 Missing authorization in Jenkins Static Analysis Utilities Plugin CVSS 3.1MEDIUM 6.5
- TI-2020-02193 Cross-site scripting in Jenkins Static Analysis Utilities Plugin CVSS 3.1MEDIUM 5.4
- TI-2017-14439 The Details view of some Static Analysis Utilities based plugins, was vulnerable to a… CVSS 3.0MEDIUM 5.4
Sources
- CVE-2019-10307 · CVE Program
- CVE-2019-10307 · NVD
- FIRST EPSS
- GHSA-3v9f-4vff-rx42 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences