Jenkins GitHub Authentication Plugin 0.31 and earlier did not use the state parameter of OAuth to prevent CSRF.
Priority MEDIUM 42CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Jenkins GitHub Authentication Plugin 0.31 and earlier did not use the state parameter of OAuth to prevent CSRF.
Why it matters now
EPSS 0.02161 82nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:github-oauth (Maven): 0.32
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins GitHub Authentication Plugin | up to 0.31 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:github-oauth (Maven) | before 0.32 | 0.32 | Patch available | GHSA-phwv-crgp-9r69 |
- Jenkins GitHub Authentication Plugin VendorJenkins Affected up to 0.31 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:github-oauth (Maven) Vendor— Affected before 0.32 Fixed in 0.32 Patch available GHSA-phwv-crgp-9r69
Remediation
- Fix · GHSA-phwv-crgp-9r69 org.jenkins-ci.plugins:github-oauth (Maven) Fixed in 0.32 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10315
- 2026-10-03 Alias added: GHSA-phwv-crgp-9r69
References
Sources
- CVE-2019-10315 · CVE Program
- CVE-2019-10315 · NVD
- FIRST EPSS
- GHSA-phwv-crgp-9r69 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences