Insufficiently protected credentials in Jenkins Mashup Portlets Plugin
Priority MEDIUM 42CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins Mashup Portlets Plugin stored credentials unencrypted on the Jenkins master where they can be viewed by users with access to the master file system.
Why it matters now
EPSS 0.01814 78th percentileScored 2026-11-07
Fix Fixed javagh.jenkins:mashup-portlets-plugin (Maven): 1.1.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Mashup Portlets Plugin | up to 1.0.9 | — | No fix listed | CNA |
| — | javagh.jenkins:mashup-portlets-plugin (Maven) | before 1.1.0 | 1.1.0 | Patch available | GHSA-9p5v-6p5f-f28h |
- Jenkins Mashup Portlets Plugin VendorJenkins Affected up to 1.0.9 Fixed in — No fix listed CNA
- javagh.jenkins:mashup-portlets-plugin (Maven) Vendor— Affected before 1.1.0 Fixed in 1.1.0 Patch available GHSA-9p5v-6p5f-f28h
Remediation
- Fix · GHSA-9p5v-6p5f-f28h javagh.jenkins:mashup-portlets-plugin (Maven) Fixed in 1.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10347
- 2026-10-03 Alias added: GHSA-9p5v-6p5f-f28h
References
More Jenkins Mashup Portlets vulnerabilities
- TI-2023-13197 Cross-site scripting in Jenkins Mashup Portlets Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2019-10347 · CVE Program
- CVE-2019-10347 · NVD
- FIRST EPSS
- GHSA-9p5v-6p5f-f28h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences