Cross-site scripting in Jenkins Maven Release Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A stored cross site scripting vulnerability in Jenkins Maven Release Plugin 0.14.0 and earlier allowed attackers to inject arbitrary HTML and JavaScript in the plugin-provided web pages in Jenkins.
Why it matters now
EPSS 0.00688 52nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins.m2release:m2release (Maven): 0.15.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Maven Release Plugin | up to 0.14.0 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins.m2release:m2release (Maven) | before 0.15.0 | 0.15.0 | Patch available | GHSA-79rm-f26g-296p |
- Jenkins Maven Release Plugin VendorJenkins Affected up to 0.14.0 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins.m2release:m2release (Maven) Vendor— Affected before 0.15.0 Fixed in 0.15.0 Patch available GHSA-79rm-f26g-296p
Remediation
- Fix · GHSA-79rm-f26g-296p org.jenkins-ci.plugins.m2release:m2release (Maven) Fixed in 0.15.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10360
- 2026-10-03 Alias added: GHSA-79rm-f26g-296p
References
Sources
- CVE-2019-10360 · CVE Program
- CVE-2019-10360 · NVD
- FIRST EPSS
- GHSA-79rm-f26g-296p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences