Insufficiently protected credentials in Jenkins Maven Release Plugin
Priority LOW 25CWE-522Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins Maven Release Plugin 0.14.0 and earlier stored credentials unencrypted on the Jenkins master where they could be viewed by users with access to the master file system.
Why it matters now
EPSS 0.00471 41st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins.m2release:m2release (Maven): 0.15.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Maven Release Plugin | up to 0.14.0 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins.m2release:m2release (Maven) | before 0.15.0 | 0.15.0 | Patch available | GHSA-vwx8-qpqh-qwm9 |
- Jenkins Maven Release Plugin VendorJenkins Affected up to 0.14.0 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins.m2release:m2release (Maven) Vendor— Affected before 0.15.0 Fixed in 0.15.0 Patch available GHSA-vwx8-qpqh-qwm9
Remediation
- Fix · GHSA-vwx8-qpqh-qwm9 org.jenkins-ci.plugins.m2release:m2release (Maven) Fixed in 0.15.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10361
- 2026-10-03 Alias added: GHSA-vwx8-qpqh-qwm9
References
Advisory 4
More Jenkins M2release vulnerabilities
- TI-2019-07668 Cross-site request forgery in Jenkins Maven Release Plugin CVSS 3.1MEDIUM 6.3
Sources
- CVE-2019-10361 · CVE Program
- CVE-2019-10361 · NVD
- FIRST EPSS
- GHSA-vwx8-qpqh-qwm9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences