Cross-site scripting in Jenkins Build Environment Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Build Environment Plugin 1.6 and earlier did not escape variables shown on its views, resulting in a cross-site scripting vulnerability in Jenkins 2.145, 2.138.1, or older, exploitable by users able to change various job/build properties.
Why it matters now
EPSS 0.00688 52nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:build-environment (Maven): 1.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Build Environment Plugin | up to 1.6 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:build-environment (Maven) | before 1.7 | 1.7 | Patch available | GHSA-88qj-3q6h-8m5q |
- Jenkins Build Environment Plugin VendorJenkins Affected up to 1.6 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:build-environment (Maven) Vendor— Affected before 1.7 Fixed in 1.7 Patch available GHSA-88qj-3q6h-8m5q
Remediation
- Fix · GHSA-88qj-3q6h-8m5q org.jenkins-ci.plugins:build-environment (Maven) Fixed in 1.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10395
- 2026-10-03 Alias added: GHSA-88qj-3q6h-8m5q
References
Sources
- CVE-2019-10395 · CVE Program
- CVE-2019-10395 · NVD
- FIRST EPSS
- GHSA-88qj-3q6h-8m5q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences