Read the docs
TI-2019-07705 Aliases CVE-2019-10396GHSA-fv4q-4h24-23qr

Cross-site scripting in Jenkins Dashboard View Plugin

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Jenkins Dashboard View Plugin 2.11 and earlier did not escape build descriptions, resulting in a cross-site scripting vulnerability exploitable by users able to change build descriptions.

Why it matters now

EPSS 0.00735 54th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:dashboard-view (Maven): 2.12

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Dashboard View Pluginup to 2.11—No fix listedCNA
—org.jenkins-ci.plugins:dashboard-view (Maven)before 2.122.12Patch availableGHSA-fv4q-4h24-23qr
  • Jenkins Dashboard View Plugin VendorJenkins Affected up to 2.11 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:dashboard-view (Maven) Vendor— Affected before 2.12 Fixed in 2.12 Patch available GHSA-fv4q-4h24-23qr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:dashboard_view:*:*:*:*:*:jenkins:*:*up to 2.11VulnerableJenkins
  • cpe:2.3:a:jenkins:dashboard_view:*:*:*:*:*:jenkins:*:* Versions up to 2.11 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-fv4q-4h24-23qr org.jenkins-ci.plugins:dashboard-view (Maven) Fixed in 2.12 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10396
  2. 2026-10-03 Alias added: GHSA-fv4q-4h24-23qr

References

  • TI-2021-04729 Cross-site scripting in Jenkins Dashboard View Plugin CVSS 3.1MEDIUM 5.4
  • TI-2022-10319 Cross-site scripting in Jenkins Dashboard View Plugin CVSS 3.1MEDIUM 5.4

Sources