Cross-site scripting in Jenkins Log Parser Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Log Parser Plugin 2.0 and earlier did not escape an error message, resulting in a cross-site scripting vulnerability exploitable by users able to define log parsing rules.
Why it matters now
EPSS 0.00882 59th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:log-parser (Maven): 2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Log Parser Plugin | up to 2.0 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:log-parser (Maven) | before 2.1 | 2.1 | Patch available | GHSA-xqqw-cqjp-52xm |
- Jenkins Log Parser Plugin VendorJenkins Affected up to 2.0 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:log-parser (Maven) Vendor— Affected before 2.1 Fixed in 2.1 Patch available GHSA-xqqw-cqjp-52xm
Remediation
- Fix · GHSA-xqqw-cqjp-52xm org.jenkins-ci.plugins:log-parser (Maven) Fixed in 2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10410
- 2026-10-03 Alias added: GHSA-xqqw-cqjp-52xm
References
Sources
- CVE-2019-10410 · CVE Program
- CVE-2019-10410 · NVD
- FIRST EPSS
- GHSA-xqqw-cqjp-52xm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences