Uncontrolled resource consumption in deeply
Priority MEDIUM 45CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
deeply is vulnerable to Prototype Pollution in versions before 3.1.0. The function assign-deep could be tricked into adding or modifying properties of Object.prototype using using a _proto_ payload.
Why it matters now
EPSS 0.01691 77th percentileScored 2026-11-07
Fix Fixed deeply (npm): 3.1.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | deeply | All versions prior to version 3.1.0 | — | No fix listed | CNA |
| — | deeply (npm) | before 3.1.0 | 3.1.0 | Patch available | GHSA-8j4w-5fw4-rm27 |
- deeply Vendor— Affected All versions prior to version 3.1.0 Fixed in — No fix listed CNA
- deeply (npm) Vendor— Affected before 3.1.0 Fixed in 3.1.0 Patch available GHSA-8j4w-5fw4-rm27
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:deeply_project:deeply:*:*:*:*:*:node.js:*:* | before 3.1.0 | Vulnerable | Deeply Project |
- cpe:2.3:a:deeply_project:deeply:*:*:*:*:*:node.js:*:* Versions before 3.1.0 Vulnerable ·Deeply Project
Remediation
- Fix · GHSA-8j4w-5fw4-rm27 deeply (npm) Fixed in 3.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10750
- 2026-10-03 Alias added: GHSA-8j4w-5fw4-rm27
References
Sources
- CVE-2019-10750 · CVE Program
- CVE-2019-10750 · NVD
- FIRST EPSS
- GHSA-8j4w-5fw4-rm27 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences