columnQuote in medoo before 1.7.5 allows remote attackers to perform a SQL Injection due to improper escaping.
Priority MEDIUM 45CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
columnQuote in medoo before 1.7.5 allows remote attackers to perform a SQL Injection due to improper escaping.
Why it matters now
EPSS 0.01421 72nd percentileScored 2026-11-07
Fix Fixed catfan/medoo (Packagist): 1.7.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | medoo | All versions prior to version 1.7.5 | — | No fix listed | CNA |
| — | catfan/medoo (Packagist) | before 1.7.5 | 1.7.5 | Patch available | GHSA-q9p4-qfc8-fvpp |
- medoo Vendor— Affected All versions prior to version 1.7.5 Fixed in — No fix listed CNA
- catfan/medoo (Packagist) Vendor— Affected before 1.7.5 Fixed in 1.7.5 Patch available GHSA-q9p4-qfc8-fvpp
Remediation
- Fix · GHSA-q9p4-qfc8-fvpp catfan/medoo (Packagist) Fixed in 1.7.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10762
- 2026-10-03 Alias added: GHSA-q9p4-qfc8-fvpp
References
Sources
- CVE-2019-10762 · CVE Program
- CVE-2019-10762 · NVD
- FIRST EPSS
- GHSA-q9p4-qfc8-fvpp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences