Read the docs
TI-2019-08035 Aliases CVE-2019-10770GHSA-r2wf-q3x4-hrv9

Cross-site scripting in io.ratpack:ratpack-core

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

All versions of io.ratpack:ratpack-core from 0.9.10 inclusive and before 1.7.6 are vulnerable to Cross-site Scripting (XSS). This affects the development mode error handler when an exception message contains untrusted data. Note the production mode error handler is not vulnerable - so for this to be utilized in production it would require users to not disable development mode.

Why it matters now

EPSS 0.00857 58th percentileScored 2026-11-07
Fix Fixed io.ratpack:ratpack-core (Maven): 1.7.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—io.ratpack:ratpack-coreall versions from 0.9.10 inclusive and before 1.7.6—No fix listedCNA
—io.ratpack:ratpack-core (Maven)before 1.7.61.7.6Patch availableGHSA-r2wf-q3x4-hrv9
  • io.ratpack:ratpack-core Vendor— Affected all versions from 0.9.10 inclusive and before 1.7.6 Fixed in — No fix listed CNA
  • io.ratpack:ratpack-core (Maven) Vendor— Affected before 1.7.6 Fixed in 1.7.6 Patch available GHSA-r2wf-q3x4-hrv9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ratpack:ratpack:*:*:*:*:*:*:*:*0.9.10 to before 1.7.6Vulnerableratpack
  • cpe:2.3:a:ratpack:ratpack:*:*:*:*:*:*:*:* Versions 0.9.10 to before 1.7.6 Vulnerable ·ratpack

Remediation

  • Fix · GHSA-r2wf-q3x4-hrv9 io.ratpack:ratpack-core (Maven) Fixed in 1.7.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10770
  2. 2026-10-03 Alias added: GHSA-r2wf-q3x4-hrv9

References

Sources