Command injection in codecov
Priority LOW 31CWE-88Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-88.
Summary
This affects the package codecov before 2.0.16. The vulnerability occurs due to not sanitizing gcov arguments before being being provided to the popen method.
Why it matters now
EPSS 0.01211 68th percentileScored 2026-11-07
Fix Fixed codecov: 2.0.16codecov (PyPI): 2.0.16
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | codecov | before 2.0.16 | 2.0.16 | Patch available | CNA |
| — | codecov (PyPI) | before 2.0.16 | 2.0.16 | Patch available | GHSA-h3qr-fjhm-jphw |
- codecov Vendor— Affected before 2.0.16 Fixed in 2.0.16 Patch available CNA
- codecov (PyPI) Vendor— Affected before 2.0.16 Fixed in 2.0.16 Patch available GHSA-h3qr-fjhm-jphw
Remediation
- Fix · CNA codecov Fixed in 2.0.16
- Fix · GHSA-h3qr-fjhm-jphw codecov (PyPI) Fixed in 2.0.16 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10800
- 2026-10-03 Alias added: GHSA-h3qr-fjhm-jphw
References
Advisory 2
Sources
- CVE-2019-10800 · CVE Program
- CVE-2019-10800 · NVD
- FIRST EPSS
- GHSA-h3qr-fjhm-jphw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences