Netskope client buffer overflow vulnerability
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-120 and the CVSS impact.
Summary
The Netskope client service, v57 before 57.2.0.219 and v60 before 60.2.0.214, running with NT\SYSTEM privilege, accepts network connections from localhost. The connection handling function in this service suffers from a stack based buffer overflow in "doHandshakefromServer" function. Local users can use this vulnerability to trigger a crash of the service and potentially cause additional impact on the system.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Netskope client (Netskope) Fixed in Netskope client 57.2.0.219, Netskope client 60.2.0.214
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Netskope client Netskope client*
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-09019 Netskope client command injections vulnerabilityPriority LOW 36
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10882
- 2026-10-03 Alias added: GHSA-p778-fw7q-x2mr
References
More Netskope vulnerabilities
- TI-2020-15056 Netskope Client through 77 allows low-privileged users to elevate their privileges to NT AUTHORITY\SYSTEM. CVSS 3.1HIGH 8.8
- TI-2024-06860 Client Enrollment Process Bypass CVSS 4.0HIGH 8.5
- TI-2023-04599 Local privilege escalation in Netskope Client CVSS 3.1HIGH 8.8
- TI-2021-20302 Sensitive Information store in NSClient logs CVSS 3.1HIGH 8.4
- TI-2023-02129 Local privilege escalation in Netskope Client CVSS 3.1HIGH 7.8
- TI-2020-17407 A CSV injection vulnerability in the Admin portal for Netskope 75.0 allows an… CVSS 3.1HIGH 7.8
Sources
- CVE-2019-10882 · CVE Program
- CVE-2019-10882 · NVD
- FIRST EPSS
- GHSA-p778-fw7q-x2mr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences