Roundup 1.6 allows XSS via the URI because frontends/roundup.cgi and roundup/cgi/wsgi_handler.py mishandle 404 errors.
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Roundup 1.6 allows XSS via the URI because frontends/roundup.cgi and roundup/cgi/wsgi_handler.py mishandle 404 errors.
Why it matters now
EPSS 0.01581 75th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed roundup (PyPI): 2.0.0alpha0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | roundup (PyPI) | before 2.0.0alpha0 | 2.0.0alpha0 | Patch available | GHSA-926q-wxr6-3crq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- roundup (PyPI) Vendor— Affected before 2.0.0alpha0 Fixed in 2.0.0alpha0 Patch available GHSA-926q-wxr6-3crq
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:a:roundup-tracker:roundup:1.6:*:*:*:*:*:*:* | 1.6 | Vulnerable | roundup-tracker |
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:a:roundup-tracker:roundup:1.6:*:*:*:*:*:*:* Versions 1.6 Vulnerable ·roundup-tracker
Remediation
- Fix · GHSA-926q-wxr6-3crq roundup (PyPI) Fixed in 2.0.0alpha0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10904
- 2026-10-03 Alias added: GHSA-926q-wxr6-3crq
References
Exploit 3
Advisory 3
Sources
- CVE-2019-10904 · CVE Program
- CVE-2019-10904 · NVD
- FIRST EPSS
- GHSA-926q-wxr6-3crq · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10904 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences