Read the docs
TI-2019-08126 Aliases CVE-2019-10905GHSA-62m3-fc7f-jpp8

Parsedown before 1.7.2, when safe mode is used and HTML markup is disabled, might allow…

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Parsedown before 1.7.2, when safe mode is used and HTML markup is disabled, might allow attackers to execute arbitrary JavaScript code if a script (already running on the affected page) executes the contents of any element with a specific class. This occurs because spaces are permitted in code block infostrings, which interferes with the intended behavior of a single class name beginning with the language- substring.

Why it matters now

EPSS 0.01469 73rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed erusev/parsedown (Packagist): 1.7.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—erusev/parsedown (Packagist)before 1.7.21.7.2Patch availableGHSA-62m3-fc7f-jpp8
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • erusev/parsedown (Packagist) Vendor— Affected before 1.7.2 Fixed in 1.7.2 Patch available GHSA-62m3-fc7f-jpp8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:parsedown:parsedown:*:*:*:*:*:*:*:*before 1.7.2VulnerableParsedown
  • cpe:2.3:a:parsedown:parsedown:*:*:*:*:*:*:*:* Versions before 1.7.2 Vulnerable ·Parsedown

Remediation

  • Fix · GHSA-62m3-fc7f-jpp8 erusev/parsedown (Packagist) Fixed in 1.7.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10905
  2. 2026-10-03 Alias added: GHSA-62m3-fc7f-jpp8

References

  • TI-2018-15813 Parsedown version prior to 1.7.0 contains a Cross Site Scripting (XSS) vulnerability in… CVSS 3.0MEDIUM 6.1

Sources