In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and…
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, validation messages are not escaped, which can lead to XSS when user input is included. This is related to symfony/framework-bundle.
Why it matters now
EPSS 0.01029 63rd percentileScored 2026-11-07
Fix Fixed symfony/symfony (Packagist): 2.7.51, 2.8.50, 3.4.26 +2symfony/framework-bundle (Packagist): 2.7.51, 2.8.50, 3.4.26 +2+2 more products
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | symfony/symfony (Packagist) | 2.7.0 to before 2.7.51 | 2.7.51 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | symfony/symfony (Packagist) | 2.8.0 to before 2.8.50 | 2.8.50 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | symfony/symfony (Packagist) | 3.0.0 to before 3.4.26 | 3.4.26 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | symfony/symfony (Packagist) | 4.0.0 to before 4.1.12 | 4.1.12 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | symfony/symfony (Packagist) | 4.2.0 to before 4.2.7 | 4.2.7 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | symfony/framework-bundle (Packagist) | 2.7.0 to before 2.7.51 | 2.7.51 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | symfony/framework-bundle (Packagist) | 2.8.0 to before 2.8.50 | 2.8.50 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | symfony/framework-bundle (Packagist) | 3.0.0 to before 3.4.26 | 3.4.26 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | symfony/framework-bundle (Packagist) | 4.0.0 to before 4.1.12 | 4.1.12 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | symfony/framework-bundle (Packagist) | 4.2.0 to before 4.2.7 | 4.2.7 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | drupal/core (Packagist) | 8.0.0 to before 8.5.15 | 8.5.15 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | drupal/core (Packagist) | 8.6.0 to before 8.6.15 | 8.6.15 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | drupal/drupal (Packagist) | 8.0.0 to before 8.5.15 | 8.5.15 | Patch available | GHSA-g996-q5r8-w7g2 |
| — | drupal/drupal (Packagist) | 8.6.0 to before 8.6.15 | 8.6.15 | Patch available | GHSA-g996-q5r8-w7g2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- symfony/symfony (Packagist) Vendor— Affected 2.7.0 to before 2.7.51 Fixed in 2.7.51 Patch available GHSA-g996-q5r8-w7g2
- symfony/symfony (Packagist) Vendor— Affected 2.8.0 to before 2.8.50 Fixed in 2.8.50 Patch available GHSA-g996-q5r8-w7g2
- symfony/symfony (Packagist) Vendor— Affected 3.0.0 to before 3.4.26 Fixed in 3.4.26 Patch available GHSA-g996-q5r8-w7g2
- symfony/symfony (Packagist) Vendor— Affected 4.0.0 to before 4.1.12 Fixed in 4.1.12 Patch available GHSA-g996-q5r8-w7g2
- symfony/symfony (Packagist) Vendor— Affected 4.2.0 to before 4.2.7 Fixed in 4.2.7 Patch available GHSA-g996-q5r8-w7g2
- symfony/framework-bundle (Packagist) Vendor— Affected 2.7.0 to before 2.7.51 Fixed in 2.7.51 Patch available GHSA-g996-q5r8-w7g2
- symfony/framework-bundle (Packagist) Vendor— Affected 2.8.0 to before 2.8.50 Fixed in 2.8.50 Patch available GHSA-g996-q5r8-w7g2
- symfony/framework-bundle (Packagist) Vendor— Affected 3.0.0 to before 3.4.26 Fixed in 3.4.26 Patch available GHSA-g996-q5r8-w7g2
- symfony/framework-bundle (Packagist) Vendor— Affected 4.0.0 to before 4.1.12 Fixed in 4.1.12 Patch available GHSA-g996-q5r8-w7g2
- symfony/framework-bundle (Packagist) Vendor— Affected 4.2.0 to before 4.2.7 Fixed in 4.2.7 Patch available GHSA-g996-q5r8-w7g2
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.5.15 Fixed in 8.5.15 Patch available GHSA-g996-q5r8-w7g2
- drupal/core (Packagist) Vendor— Affected 8.6.0 to before 8.6.15 Fixed in 8.6.15 Patch available GHSA-g996-q5r8-w7g2
- drupal/drupal (Packagist) Vendor— Affected 8.0.0 to before 8.5.15 Fixed in 8.5.15 Patch available GHSA-g996-q5r8-w7g2
- drupal/drupal (Packagist) Vendor— Affected 8.6.0 to before 8.6.15 Fixed in 8.6.15 Patch available GHSA-g996-q5r8-w7g2
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 2.7.0 to before 2.7.51; 2.8.0 to before 2.8.50; 3.4.0 to before 3.4.26; 4.1.0 to before 4.1.12; 4.2.0 to before 4.2.7 | Vulnerable | sensiolabs |
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 8.5.0 to before 8.5.15; 8.6.0 to before 8.6.15 | Vulnerable | Drupal |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.7.51; 2.8.0 to before 2.8.50; 3.4.0 to before 3.4.26; 4.1.0 to before 4.1.12; 4.2.0 to before 4.2.7 Vulnerable ·sensiolabs
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.5.0 to before 8.5.15; 8.6.0 to before 8.6.15 Vulnerable ·Drupal
Remediation
- Fix · GHSA-g996-q5r8-w7g2 symfony/symfony (Packagist) Fixed in 2.7.51 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 symfony/symfony (Packagist) Fixed in 2.8.50 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 symfony/symfony (Packagist) Fixed in 3.4.26 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 symfony/symfony (Packagist) Fixed in 4.1.12 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 symfony/symfony (Packagist) Fixed in 4.2.7 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 symfony/framework-bundle (Packagist) Fixed in 2.7.51 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 symfony/framework-bundle (Packagist) Fixed in 2.8.50 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 symfony/framework-bundle (Packagist) Fixed in 3.4.26 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 symfony/framework-bundle (Packagist) Fixed in 4.1.12 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 symfony/framework-bundle (Packagist) Fixed in 4.2.7 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 drupal/core (Packagist) Fixed in 8.5.15 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 drupal/core (Packagist) Fixed in 8.6.15 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 drupal/drupal (Packagist) Fixed in 8.5.15 Advisory →
- Fix · GHSA-g996-q5r8-w7g2 drupal/drupal (Packagist) Fixed in 8.6.15 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10909
- 2026-10-03 Alias added: GHSA-g996-q5r8-w7g2
References
Advisory 4
Other 5
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2019-10909.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2019-10909.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/framework-bundle/CVE-2019-10909.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2019-10909.yaml
- https://symfony.com/cve-2019-10909
Sources
- CVE-2019-10909 · CVE Program
- CVE-2019-10909 · NVD
- FIRST EPSS
- GHSA-g996-q5r8-w7g2 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10909 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences