In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and…
Priority LOW 35CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass, Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287 and CWE-200.
Summary
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, a vulnerability would allow an attacker to authenticate as a privileged user on sites with user registration and remember me login functionality enabled. This is related to symfony/security.
Why it matters now
EPSS 0.01215 68th percentileScored 2026-11-07
Fix Fixed symfony/security-http (Packagist): 2.7.51, 2.8.50, 3.4.26 +2symfony/security (Packagist): 2.7.51, 2.8.50, 3.4.26 +2+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | symfony/security-http (Packagist) | 2.7.0 to before 2.7.51 | 2.7.51 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/security-http (Packagist) | 2.8.0 to before 2.8.50 | 2.8.50 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/security-http (Packagist) | 3.0.0 to before 3.4.26 | 3.4.26 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/security-http (Packagist) | 4.0.0 to before 4.1.12 | 4.1.12 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/security-http (Packagist) | 4.2.0 to before 4.2.7 | 4.2.7 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/security (Packagist) | 2.7.0 to before 2.7.51 | 2.7.51 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/security (Packagist) | 2.8.0 to before 2.8.50 | 2.8.50 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/security (Packagist) | 3.0.0 to before 3.4.26 | 3.4.26 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/security (Packagist) | 4.0.0 to before 4.1.12 | 4.1.12 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/security (Packagist) | 4.2.0 to before 4.2.7 | 4.2.7 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/symfony (Packagist) | 2.7.0 to before 2.7.51 | 2.7.51 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/symfony (Packagist) | 2.8.0 to before 2.8.50 | 2.8.50 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/symfony (Packagist) | 3.0.0 to before 3.4.26 | 3.4.26 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/symfony (Packagist) | 4.0.0 to before 4.1.12 | 4.1.12 | Patch available | GHSA-cchx-mfrc-fwqr |
| — | symfony/symfony (Packagist) | 4.2.0 to before 4.2.7 | 4.2.7 | Patch available | GHSA-cchx-mfrc-fwqr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- symfony/security-http (Packagist) Vendor— Affected 2.7.0 to before 2.7.51 Fixed in 2.7.51 Patch available GHSA-cchx-mfrc-fwqr
- symfony/security-http (Packagist) Vendor— Affected 2.8.0 to before 2.8.50 Fixed in 2.8.50 Patch available GHSA-cchx-mfrc-fwqr
- symfony/security-http (Packagist) Vendor— Affected 3.0.0 to before 3.4.26 Fixed in 3.4.26 Patch available GHSA-cchx-mfrc-fwqr
- symfony/security-http (Packagist) Vendor— Affected 4.0.0 to before 4.1.12 Fixed in 4.1.12 Patch available GHSA-cchx-mfrc-fwqr
- symfony/security-http (Packagist) Vendor— Affected 4.2.0 to before 4.2.7 Fixed in 4.2.7 Patch available GHSA-cchx-mfrc-fwqr
- symfony/security (Packagist) Vendor— Affected 2.7.0 to before 2.7.51 Fixed in 2.7.51 Patch available GHSA-cchx-mfrc-fwqr
- symfony/security (Packagist) Vendor— Affected 2.8.0 to before 2.8.50 Fixed in 2.8.50 Patch available GHSA-cchx-mfrc-fwqr
- symfony/security (Packagist) Vendor— Affected 3.0.0 to before 3.4.26 Fixed in 3.4.26 Patch available GHSA-cchx-mfrc-fwqr
- symfony/security (Packagist) Vendor— Affected 4.0.0 to before 4.1.12 Fixed in 4.1.12 Patch available GHSA-cchx-mfrc-fwqr
- symfony/security (Packagist) Vendor— Affected 4.2.0 to before 4.2.7 Fixed in 4.2.7 Patch available GHSA-cchx-mfrc-fwqr
- symfony/symfony (Packagist) Vendor— Affected 2.7.0 to before 2.7.51 Fixed in 2.7.51 Patch available GHSA-cchx-mfrc-fwqr
- symfony/symfony (Packagist) Vendor— Affected 2.8.0 to before 2.8.50 Fixed in 2.8.50 Patch available GHSA-cchx-mfrc-fwqr
- symfony/symfony (Packagist) Vendor— Affected 3.0.0 to before 3.4.26 Fixed in 3.4.26 Patch available GHSA-cchx-mfrc-fwqr
- symfony/symfony (Packagist) Vendor— Affected 4.0.0 to before 4.1.12 Fixed in 4.1.12 Patch available GHSA-cchx-mfrc-fwqr
- symfony/symfony (Packagist) Vendor— Affected 4.2.0 to before 4.2.7 Fixed in 4.2.7 Patch available GHSA-cchx-mfrc-fwqr
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* | 2.7.0 to before 2.7.51; 2.8.0 to before 2.8.50; 3.4.0 to before 3.4.26; 4.1.0 to before 4.1.12; 4.2.0 to before 4.2.7 | Vulnerable | sensiolabs |
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 8.5.0 to before 8.5.15; 8.6.0 to before 8.6.15 | Vulnerable | Drupal |
- cpe:2.3:a:sensiolabs:symfony:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.7.51; 2.8.0 to before 2.8.50; 3.4.0 to before 3.4.26; 4.1.0 to before 4.1.12; 4.2.0 to before 4.2.7 Vulnerable ·sensiolabs
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.5.0 to before 8.5.15; 8.6.0 to before 8.6.15 Vulnerable ·Drupal
Remediation
- Fix · GHSA-cchx-mfrc-fwqr symfony/security-http (Packagist) Fixed in 2.7.51 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/security-http (Packagist) Fixed in 2.8.50 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/security-http (Packagist) Fixed in 3.4.26 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/security-http (Packagist) Fixed in 4.1.12 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/security-http (Packagist) Fixed in 4.2.7 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/security (Packagist) Fixed in 2.7.51 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/security (Packagist) Fixed in 2.8.50 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/security (Packagist) Fixed in 3.4.26 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/security (Packagist) Fixed in 4.1.12 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/security (Packagist) Fixed in 4.2.7 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/symfony (Packagist) Fixed in 2.7.51 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/symfony (Packagist) Fixed in 2.8.50 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/symfony (Packagist) Fixed in 3.4.26 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/symfony (Packagist) Fixed in 4.1.12 Advisory →
- Fix · GHSA-cchx-mfrc-fwqr symfony/symfony (Packagist) Fixed in 4.2.7 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10911
- 2026-10-03 Alias added: GHSA-cchx-mfrc-fwqr
References
Advisory 3
Other 5
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security-http/CVE-2019-10911.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/security/CVE-2019-10911.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2019-10911.yaml
- https://github.com/symfony/symfony
- https://symfony.com/cve-2019-10911
Sources
- CVE-2019-10911 · CVE Program
- CVE-2019-10911 · NVD
- FIRST EPSS
- GHSA-cchx-mfrc-fwqr · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10911 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences