Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when…
Priority LOW 29CWE-319Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-319.
Summary
Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.
Why it matters now
EPSS 0.0136 71st percentileScored 2026-11-07
Fix Partial org.gradle:gradle-core (Maven): 5.4.0Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.gradle:gradle-core (Maven) | 1.4 to before 5.4.0 | 5.4.0 | Patch available | GHSA-pprq-4488-wgqx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.gradle:gradle-core (Maven) Vendor— Affected 1.4 to before 5.4.0 Fixed in 5.4.0 Patch available GHSA-pprq-4488-wgqx
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gradle:gradle:*:*:*:*:*:*:*:* | 1.4 – 5.3.1 | Vulnerable | gradle |
| cpe:2.3:o:fedoraproject:fedora:28:*:*:*:*:*:*:* | 28 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:* | 29 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* | 30 | Vulnerable | Fedoraproject |
- cpe:2.3:a:gradle:gradle:*:*:*:*:*:*:*:* Versions 1.4 – 5.3.1 Vulnerable ·gradle
- cpe:2.3:o:fedoraproject:fedora:28:*:*:*:*:*:*:* Versions 28 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:* Versions 29 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-pprq-4488-wgqx org.gradle:gradle-core (Maven) Fixed in 5.4.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat JBoss Enterprise Web Server 3 | Affected | No fix planned: Out of support scope |
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11065
- 2026-10-03 Alias added: GHSA-pprq-4488-wgqx
References
Advisory 4
Other 4
- https://github.com/gradle/gradle
- https://lists.fedoraproject.org/archives/list/[email protected]/message/WVXOXNLAYRGPKAZV63PYNV3HF27JW2MW
- https://lists.fedoraproject.org/archives/list/[email protected]/message/Y43P7SVDJOG6OUDVFR4ZIDITZLNHPGTO
- https://lists.fedoraproject.org/archives/list/[email protected]/message/YQ5CGOV5QVQCSPGE3WRZDKUGIXLHSZDR
Sources
- CVE-2019-11065 · CVE Program
- CVE-2019-11065 · NVD
- FIRST EPSS
- GHSA-pprq-4488-wgqx · GitHub Advisory Database · CC BY 4.0
- CVE-2019-11065 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences