Kubernetes kube-apiserver allows access to custom resources via wrong scope
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-863.
Summary
The Kubernetes kube-apiserver mistakenly allows access to a cluster-scoped custom resource if the request is made as if the resource were namespaced. Authorizations for the resource accessed in this manner are enforced using roles and role bindings within the namespace, meaning that a user with access only to a resource in one namespace could create, view update or delete the cluster-scoped resource (according to their namespace role privileges). Kubernetes affected versions include versions prior to 1.13.9, versions prior to 1.14.5, versions prior to 1.15.2, and versions 1.7, 1.8, 1.9, 1.10, 1.11, 1.12.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Kubernetes | Kubernetes | before 1.13.9; before 1.14.5; before 1.15.2; 1.7; 1.8; 1.9; 1.10; 1.11; 1.12 | 1.13.9, 1.14.5, 1.15.2 | Patch available | CNA |
| — | k8s.io/apiextensions-apiserver (Go) | 0.7.0 to before 0.13.9 | 0.13.9 | Patch available | GHSA-fp37-c92q-4pwq |
| — | k8s.io/apiextensions-apiserver (Go) | 0.14.0 to before 0.14.5 | 0.14.5 | Patch available | GHSA-fp37-c92q-4pwq |
| — | k8s.io/apiextensions-apiserver (Go) | 0.15.0 to before 0.15.2 | 0.15.2 | Patch available | GHSA-fp37-c92q-4pwq |
- Kubernetes VendorKubernetes Affected before 1.13.9; before 1.14.5; before 1.15.2; 1.7; 1.8; 1.9; 1.10; 1.11; 1.12 Fixed in 1.13.9, 1.14.5, 1.15.2 Patch available CNA
- k8s.io/apiextensions-apiserver (Go) Vendor— Affected 0.7.0 to before 0.13.9 Fixed in 0.13.9 Patch available GHSA-fp37-c92q-4pwq
- k8s.io/apiextensions-apiserver (Go) Vendor— Affected 0.14.0 to before 0.14.5 Fixed in 0.14.5 Patch available GHSA-fp37-c92q-4pwq
- k8s.io/apiextensions-apiserver (Go) Vendor— Affected 0.15.0 to before 0.15.2 Fixed in 0.15.2 Patch available GHSA-fp37-c92q-4pwq
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:* | 1.7.0 – 1.12.10; 1.13.0 to before 1.13.9; 1.14.0 to before 1.14.5; 1.15.0 to before 1.15.2 | Vulnerable | Kubernetes |
| cpe:2.3:a:kubernetes:kubernetes:1.12.11:beta0:*:*:*:*:*:* | 1.12.11 beta0 | Vulnerable | Kubernetes |
| cpe:2.3:a:redhat:openshift_container_platform:3.9:*:*:*:*:*:*:* | 3.9 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openshift_container_platform:3.10:*:*:*:*:*:*:* | 3.10 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* | 3.11 | Vulnerable | Red Hat |
- cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:* Versions 1.7.0 – 1.12.10; 1.13.0 to before 1.13.9; 1.14.0 to before 1.14.5; 1.15.0 to before 1.15.2 Vulnerable ·Kubernetes
- cpe:2.3:a:kubernetes:kubernetes:1.12.11:beta0:*:*:*:*:*:* Versions 1.12.11 beta0 Vulnerable ·Kubernetes
- cpe:2.3:a:redhat:openshift_container_platform:3.9:*:*:*:*:*:*:* Versions 3.9 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openshift_container_platform:3.10:*:*:*:*:*:*:* Versions 3.10 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* Versions 3.11 Vulnerable ·Red Hat
Remediation
- Fix · CNA Kubernetes (Kubernetes) Fixed in 1.13.9, 1.14.5, 1.15.2
- Fix · GHSA-fp37-c92q-4pwq k8s.io/apiextensions-apiserver (Go) Fixed in 0.13.9 Advisory →
- Fix · GHSA-fp37-c92q-4pwq k8s.io/apiextensions-apiserver (Go) Fixed in 0.14.5 Advisory →
- Fix · GHSA-fp37-c92q-4pwq k8s.io/apiextensions-apiserver (Go) Fixed in 0.15.2 Advisory →
Red Hat 3 advisories
- RHSA-2019:2769 Released 2019-10-24 · Red Hat rating ImportantOpenShift Container Platform 3.9 security update
- Red Hat OpenShift Container Platform 3.9 ansible-service-broker-1.1.20-2.el7, ansible-service-broker-container-scripts-1.1.20-2.el7, ansible-service-broker-selinux-1.1.20-2.el7 +44
- RHSA-2019:2690 Released 2019-09-12 · Red Hat rating ImportantOpenShift Container Platform 3.10 security update
- Red Hat OpenShift Container Platform 3.10 atomic-openshift-3.10.170-1.git.0.8e592d6.el7, atomic-openshift-clients-3.10.170-1.git.0.8e592d6.el7, atomic-openshift-clients-redistributable-3.10.170-1.git.0.8e592d6.el7 +10
- RHSA-2019:2504 Released 2019-08-15 · Red Hat rating ModerateOpenShift Container Platform 4.1.11 openshift security update
- Red Hat OpenShift Container Platform 4.1 openshift-4.1.10-201908060758.git.0.d81afa6.el7, openshift-4.1.10-201908060758.git.0.d81afa6.el8, openshift-clients-4.1.10-201908060758.git.0.d81afa6.el7 +5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Kubernetes — RHBA-2019:2816
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-08419 kubectl cp allows symlink directory traversalPriority LOW 35
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Fixed | RHSA-2019:2690 |
| Red Hat OpenShift Container Platform 3.11 | Fixed | — |
| Red Hat OpenShift Container Platform 3.9 | Fixed | RHSA-2019:2769 |
| Red Hat OpenShift Container Platform 4.1 | Fixed | RHSA-2019:2504 |
Not affected: 2 products
- Red Hat OpenShift Container Platform 3.11
- Red Hat Storage 3
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11247
- 2026-10-03 Alias added: GHSA-fp37-c92q-4pwq
References
Advisory 8
Other 7
- https://github.com/kubernetes/kubernetes/pull/80750
- https://github.com/kubernetes/kubernetes/pull/80850
- https://github.com/kubernetes/kubernetes/pull/80851
- https://github.com/kubernetes/kubernetes/pull/80852
- https://github.com/kubernetes/apiextensions-apiserver/commit/b9b7d2b3f32f8edbeb47b8726710eeb868bce196
- https://github.com/kubernetes/apiextensions-apiserver
- https://security.netapp.com/advisory/ntap-20190919-0003
More Kubernetes vulnerabilities
- TI-2018-16130 Improper privilege management in Kubernetes CVSS 3.0CRITICAL 9.8
- TI-2019-08418 Kubernetes kubelet exposes /debug/pprof info on healthz port CVSS 3.1HIGH 8.2
- TI-2023-05086 Kubernetes - Windows nodes - Insufficient input sanitization in in-tree storage plugin leads to privilege escalation CVSS 3.1HIGH 8.8
- TI-2023-03433 Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation CVSS 3.1HIGH 8.8
- TI-2023-02285 Bypass of seccomp profile enforcement CVSS 3.1MEDIUM 5.5
- TI-2017-14755 Link following in Kubernetes CVSS 3.0CRITICAL 9.6
Sources
- CVE-2019-11247 · CVE Program
- CVE-2019-11247 · NVD
- FIRST EPSS
- GHSA-fp37-c92q-4pwq · GitHub Advisory Database · CC BY 4.0
- CVE-2019-11247 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences