Kubernetes client-go logs authorization headers at debug verbosity levels
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 2 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-532.
Summary
The Kubernetes client-go library logs request headers at verbosity levels of 7 or higher. This can disclose credentials to unauthorized users via logs or command output. Kubernetes components (such as kube-apiserver) prior to v1.16.0, which make use of basic or bearer token authentication, and run at high verbosity levels, are affected.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Kubernetes | Kubernetes | before 1.16 | 1.16 | Patch available | CNA |
| — | k8s.io/client-go (Go) | before 0.17.0 | 0.17.0 | Patch available | GHSA-jmrx-5g74-6v2f |
| — | k8s.io/kubernetes (Go) | before 1.16.0-beta.1 | 1.16.0-beta.1 | Patch available | GHSA-jmrx-5g74-6v2f |
- Kubernetes VendorKubernetes Affected before 1.16 Fixed in 1.16 Patch available CNA
- k8s.io/client-go (Go) Vendor— Affected before 0.17.0 Fixed in 0.17.0 Patch available GHSA-jmrx-5g74-6v2f
- k8s.io/kubernetes (Go) Vendor— Affected before 1.16.0-beta.1 Fixed in 1.16.0-beta.1 Patch available GHSA-jmrx-5g74-6v2f
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:* | before 1.15.3 | Vulnerable | Kubernetes |
| cpe:2.3:a:kubernetes:kubernetes:1.15.3:-:*:*:*:*:*:* | 1.15.3 | Vulnerable | Kubernetes |
| cpe:2.3:a:kubernetes:kubernetes:1.15.4:beta0:*:*:*:*:*:* | 1.15.4 beta0 | Vulnerable | Kubernetes |
| cpe:2.3:a:kubernetes:kubernetes:1.16.0:alpha1:*:*:*:*:*:* | 1.16.0 alpha1 | Vulnerable | Kubernetes |
| cpe:2.3:a:kubernetes:kubernetes:1.16.0:alpha2:*:*:*:*:*:* | 1.16.0 alpha2 | Vulnerable | Kubernetes |
| cpe:2.3:a:kubernetes:kubernetes:1.16.0:alpha3:*:*:*:*:*:* | 1.16.0 alpha3 | Vulnerable | Kubernetes |
| cpe:2.3:a:kubernetes:kubernetes:1.16.0:beta1:*:*:*:*:*:* | 1.16.0 beta1 | Vulnerable | Kubernetes |
| cpe:2.3:a:kubernetes:kubernetes:1.16.0:beta2:*:*:*:*:*:* | 1.16.0 beta2 | Vulnerable | Kubernetes |
| cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* | 3.11 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openshift_container_platform:4.1:*:*:*:*:*:*:* | 4.1 | Vulnerable | Red Hat |
- cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:* Versions before 1.15.3 Vulnerable ·Kubernetes
- cpe:2.3:a:kubernetes:kubernetes:1.15.3:-:*:*:*:*:*:* Versions 1.15.3 Vulnerable ·Kubernetes
- cpe:2.3:a:kubernetes:kubernetes:1.15.4:beta0:*:*:*:*:*:* Versions 1.15.4 beta0 Vulnerable ·Kubernetes
- cpe:2.3:a:kubernetes:kubernetes:1.16.0:alpha1:*:*:*:*:*:* Versions 1.16.0 alpha1 Vulnerable ·Kubernetes
- cpe:2.3:a:kubernetes:kubernetes:1.16.0:alpha2:*:*:*:*:*:* Versions 1.16.0 alpha2 Vulnerable ·Kubernetes
- cpe:2.3:a:kubernetes:kubernetes:1.16.0:alpha3:*:*:*:*:*:* Versions 1.16.0 alpha3 Vulnerable ·Kubernetes
- cpe:2.3:a:kubernetes:kubernetes:1.16.0:beta1:*:*:*:*:*:* Versions 1.16.0 beta1 Vulnerable ·Kubernetes
- cpe:2.3:a:kubernetes:kubernetes:1.16.0:beta2:*:*:*:*:*:* Versions 1.16.0 beta2 Vulnerable ·Kubernetes
- cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* Versions 3.11 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openshift_container_platform:4.1:*:*:*:*:*:*:* Versions 4.1 Vulnerable ·Red Hat
Remediation
- Fix · CNA Kubernetes (Kubernetes) Fixed in 1.16
- Fix · GHSA-jmrx-5g74-6v2f k8s.io/client-go (Go) Fixed in 0.17.0 Advisory →
- Fix · GHSA-jmrx-5g74-6v2f k8s.io/kubernetes (Go) Fixed in 1.16.0-beta.1 Advisory →
Red Hat 2 advisories
- RHSA-2019:4087 Released 2019-12-17 · Red Hat rating ModerateOpenShift Container Platform 4.1 openshift security update
- Red Hat OpenShift Container Platform 4.1 openshift-4.1.27-201912021146.git.0.a40116f.el7, openshift-4.1.27-201912021146.git.0.a40116f.el8_0, openshift-clients-4.1.27-201912021146.git.0.a40116f.el7 +5
- RHSA-2019:4052 Released 2019-12-16 · Red Hat rating ModerateOpenShift Container Platform 3.11 atomic-openshift security update
- Red Hat OpenShift Container Platform 3.11 atomic-openshift-3.11.157-1.git.0.dfe38da.el7, atomic-openshift-clients-3.11.157-1.git.0.dfe38da.el7, atomic-openshift-clients-redistributable-3.11.157-1.git.0.dfe38da.el7 +10
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2019:4052 |
| Red Hat OpenShift Container Platform 4.1 | Fixed | RHSA-2019:4087 |
Not affected: 1 product
- Red Hat Edge Manager preview
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11250
- 2026-10-03 Alias added: GHSA-jmrx-5g74-6v2f
References
Advisory 5
Other 6
- [oss-security] 20201016 Kubernetes: Multiple secret leaks when verbose logging is enabled
- https://github.com/kubernetes/kubernetes/pull/81330
- https://github.com/kubernetes/kubernetes/commit/4441f1d9c3e94d9a3d93b4f184a591cab02a5245
- https://github.com/kubernetes/kubernetes
- https://pkg.go.dev/vuln/GO-2021-0065
- https://security.netapp.com/advisory/ntap-20190919-0003
More Kubernetes vulnerabilities
- TI-2018-16130 Improper privilege management in Kubernetes CVSS 3.0CRITICAL 9.8
- TI-2019-08418 Kubernetes kubelet exposes /debug/pprof info on healthz port CVSS 3.1HIGH 8.2
- TI-2023-05086 Kubernetes - Windows nodes - Insufficient input sanitization in in-tree storage plugin leads to privilege escalation CVSS 3.1HIGH 8.8
- TI-2023-03433 Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation CVSS 3.1HIGH 8.8
- TI-2023-02285 Bypass of seccomp profile enforcement CVSS 3.1MEDIUM 5.5
- TI-2017-14755 Link following in Kubernetes CVSS 3.0CRITICAL 9.6
Sources
- CVE-2019-11250 · CVE Program
- CVE-2019-11250 · NVD
- FIRST EPSS
- GHSA-jmrx-5g74-6v2f · GitHub Advisory Database · CC BY 4.0
- CVE-2019-11250 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences