Kubernetes API Server denial of service vulnerability from malicious YAML payloads
Priority LOW 35CWE-1050Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 3 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
The Kubernetes API Server component in versions 1.1-1.14, and versions prior to 1.15.10, 1.16.7 and 1.17.3 allows an authorized user who sends malicious YAML payloads to cause the kube-apiserver to consume excessive CPU cycles while parsing YAML.
Why it matters now
EPSS 0.03157 88th percentileScored 2026-11-07
Fix Partial Kubernetes (Kubernetes): 1.15.10, 1.16.7, 1.17.3gopkg.in/yaml.v2 (Go): 2.2.8Red Hat: 4 advisoriesRed Hat: 3 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Kubernetes | Kubernetes | before 1.15.10; before 1.16.7; before 1.17.3; 1.1; 1.2; 1.3; 1.4; 1.5; 1.6; 1.7; 1.8; 1.9; 1.10; 1.11; 1.12; 1.13; 1.14 | 1.15.10, 1.16.7, 1.17.3 | Patch available | CNA |
| — | gopkg.in/yaml.v2 (Go) | before 2.2.8 | 2.2.8 | Patch available | GHSA-wxc4-f4m6-wwqv |
| — | github.com/go-yaml/yaml (Go) | up to 2.1.0 | — | No fix listed | GHSA-wxc4-f4m6-wwqv |
- Kubernetes VendorKubernetes Affected before 1.15.10; before 1.16.7; before 1.17.3; 1.1; 1.2; 1.3; 1.4; 1.5; 1.6; 1.7; 1.8; 1.9; 1.10; 1.11; 1.12; 1.13; 1.14 Fixed in 1.15.10, 1.16.7, 1.17.3 Patch available CNA
- gopkg.in/yaml.v2 (Go) Vendor— Affected before 2.2.8 Fixed in 2.2.8 Patch available GHSA-wxc4-f4m6-wwqv
- github.com/go-yaml/yaml (Go) Vendor— Affected up to 2.1.0 Fixed in — No fix listed GHSA-wxc4-f4m6-wwqv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:* | before 1.15.10; 1.16.0 to before 1.16.7; 1.17.0 to before 1.17.3 | Vulnerable | Kubernetes |
- cpe:2.3:a:kubernetes:kubernetes:*:*:*:*:*:*:*:* Versions before 1.15.10; 1.16.0 to before 1.16.7; 1.17.0 to before 1.17.3 Vulnerable ·Kubernetes
Remediation
- Fix · CNA Kubernetes (Kubernetes) Fixed in 1.15.10, 1.16.7, 1.17.3
- Fix · GHSA-wxc4-f4m6-wwqv gopkg.in/yaml.v2 (Go) Fixed in 2.2.8 Advisory →
Red Hat 4 advisories
- RHSA-2020:2412 Released 2020-07-13 · Red Hat rating ModerateOpenShift Container Platform 4.5 container image security update
- Red Hat OpenShift Container Platform 4.5 openshift4/ose-cluster-logging-operator, openshift4/ose-console, openshift4/ose-hyperkube +2
- RHSA-2020:2413 Released 2020-07-13 · Red Hat rating ModerateOpenShift Container Platform 4.5 package security update
- Red Hat OpenShift Container Platform 4.5 machine-config-daemon-4.5.0-202007012112.p0.git.2527.d12c3da.el8, openshift-4.5.0-202007012112.p0.git.0.582d7fc.el7, openshift-4.5.0-202007012112.p0.git.0.582d7fc.el8 +2
- RHSA-2020:2479 Released 2020-06-18 · Red Hat rating ModerateOpenShift Container Platform 3.11 atomic-openshift security update
- Red Hat OpenShift Container Platform 3.11 atomic-openshift-3.11.232-1.git.0.a5bc32f.el7, atomic-openshift-clients-3.11.232-1.git.0.a5bc32f.el7, atomic-openshift-clients-redistributable-3.11.232-1.git.0.a5bc32f.el7 +10
Show 1 more Red Hat advisories
- RHSA-2020:0933 Released 2020-04-01 · Red Hat rating ModerateOpenShift Container Platform 4.3.9 ose-openshift-apiserver-container security update
- Red Hat OpenShift Container Platform 4.3 openshift4/ose-openshift-apiserver-rhel7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2020:2479 |
| Red Hat OpenShift Container Platform 4.3 | Fixed | RHSA-2020:0933 |
| Red Hat OpenShift Container Platform 4.5 | Fixed | RHSA-2020:2412, RHSA-2020:2413 |
Not affected: 2 products
- Red Hat OpenShift Container Platform 4
- Red Hat OpenShift Container Platform 4.5
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11254
- 2026-10-03 Alias added: GHSA-wxc4-f4m6-wwqv
References
Advisory 4
Other 6
- https://github.com/go-yaml/yaml/pull/555
- https://github.com/kubernetes/kubernetes/pull/87467/commits/b86df2bec4f377afc0ca03482ffad2f0a49a83b8
- https://github.com/go-yaml/yaml/commit/53403b58ad1b561927d19068c655246f2db79d48
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=18496
- https://pkg.go.dev/vuln/GO-2020-0036
- https://security.netapp.com/advisory/ntap-20200413-0003
More Kubernetes vulnerabilities
- TI-2018-16130 Improper privilege management in Kubernetes CVSS 3.0CRITICAL 9.8
- TI-2019-08418 Kubernetes kubelet exposes /debug/pprof info on healthz port CVSS 3.1HIGH 8.2
- TI-2023-05086 Kubernetes - Windows nodes - Insufficient input sanitization in in-tree storage plugin leads to privilege escalation CVSS 3.1HIGH 8.8
- TI-2023-03433 Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation CVSS 3.1HIGH 8.8
- TI-2023-02285 Bypass of seccomp profile enforcement CVSS 3.1MEDIUM 5.5
- TI-2017-14755 Link following in Kubernetes CVSS 3.0CRITICAL 9.6
Sources
- CVE-2019-11254 · CVE Program
- CVE-2019-11254 · NVD
- FIRST EPSS
- GHSA-wxc4-f4m6-wwqv · GitHub Advisory Database · CC BY 4.0
- CVE-2019-11254 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences