In Octopus Deploy 2019.1.0 through 2019.3.1 and 2019.4.0 through 2019.4.5, an…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
In Octopus Deploy 2019.1.0 through 2019.3.1 and 2019.4.0 through 2019.4.5, an authenticated user with the VariableViewUnscoped or VariableEditUnscoped permission scoped to a specific project could view or edit unscoped variables from a different project. (These permissions are only used in custom User Roles and do not affect built in User Roles.)
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_deploy:*:*:*:*:*:*:*:* | 2019.1.0 – 2019.3.1 | Vulnerable | Octopus Deploy |
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | 2019.4.0 – 2019.4.5 | Vulnerable | Octopus Deploy |
- cpe:2.3:a:octopus:octopus_deploy:*:*:*:*:*:*:*:* Versions 2019.1.0 – 2019.3.1 Vulnerable ·Octopus Deploy
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions 2019.4.0 – 2019.4.5 Vulnerable ·Octopus Deploy
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11632
- 2026-10-03 Alias added: GHSA-h289-298g-xpjw
References
More Octopus Deploy vulnerabilities
- TI-2020-08583 In Octopus Deploy before 2020.1.5, for customers running on-premises Active Directory… CVSS 3.1HIGH 8.8
- TI-2018-04116 An issue was discovered in Octopus Deploy before 4.1.9. CVSS 3.0HIGH 8.8
- TI-2018-03438 In Octopus Deploy versions 3.2.11 - 4.1.5 (fixed in 4.1.6), an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2017-12930 In Octopus Deploy before 4.1.3, the machine update process doesn't check that the user… CVSS 3.0HIGH 8.8
- TI-2020-15818 In Octopus Deploy 3.1.0 to 2020.4.0, certain scripts can reveal sensitive information to the user in the task logs. CVSS 3.1HIGH 7.5
- TI-2020-15047 In Octopus Deploy 2020.3.x before 2020.3.4 and 2020.4.x before 2020.4.1, if an… CVSS 3.1HIGH 7.5
Sources
- CVE-2019-11632 · CVE Program
- CVE-2019-11632 · NVD
- FIRST EPSS
- GHSA-h289-298g-xpjw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences