In PrestaShop 1.7.5.2, the shop_country parameter in the install/index.php installation…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In PrestaShop 1.7.5.2, the shop_country parameter in the install/index.php installation script/component is affected by Reflected XSS. Exploitation by a malicious actor requires the user to follow the initial stages of the setup (accepting terms and conditions) before executing the malicious link.
Why it matters now
EPSS 0.00892 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed prestashop/prestashop (Packagist): 1.7.6.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | prestashop/prestashop (Packagist) | 1.7.5.2 to before 1.7.6.0 | 1.7.6.0 | Patch available | GHSA-6grv-hw8g-4gfm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- prestashop/prestashop (Packagist) Vendor— Affected 1.7.5.2 to before 1.7.6.0 Fixed in 1.7.6.0 Patch available GHSA-6grv-hw8g-4gfm
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:prestashop:prestashop:1.7.5.2:*:*:*:*:*:*:* | 1.7.5.2 | Vulnerable | PrestaShop |
| cpe:2.3:a:drupal:drupal:8.7.0:*:*:*:*:*:*:* | 8.7.0 | Vulnerable | Drupal |
- cpe:2.3:a:prestashop:prestashop:1.7.5.2:*:*:*:*:*:*:* Versions 1.7.5.2 Vulnerable ·PrestaShop
- cpe:2.3:a:drupal:drupal:8.7.0:*:*:*:*:*:*:* Versions 8.7.0 Vulnerable ·Drupal
Remediation
- Fix · GHSA-6grv-hw8g-4gfm prestashop/prestashop (Packagist) Fixed in 1.7.6.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-11876
- 2026-10-03 Alias added: GHSA-6grv-hw8g-4gfm
References
Advisory 2
Sources
- CVE-2019-11876 · CVE Program
- CVE-2019-11876 · NVD
- FIRST EPSS
- GHSA-6grv-hw8g-4gfm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences