Blogifier 2.3 before 2019-05-11 does not properly restrict APIs, as demonstrated by…
Priority MEDIUM 46CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Blogifier 2.3 before 2019-05-11 does not properly restrict APIs, as demonstrated by missing checks for .. in a pathname.
Why it matters now
EPSS 0.01897 79th percentileScored 2026-11-07
Fix Fixed Blogifier.Core (NuGet): 2.5.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Blogifier.Core (NuGet) | before 2.5.5 | 2.5.5 | Patch available | GHSA-qcx4-gfh8-w5p5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Blogifier.Core (NuGet) Vendor— Affected before 2.5.5 Fixed in 2.5.5 Patch available GHSA-qcx4-gfh8-w5p5
Remediation
- Fix · GHSA-qcx4-gfh8-w5p5 Blogifier.Core (NuGet) Fixed in 2.5.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-12277
- 2026-10-03 Alias added: GHSA-qcx4-gfh8-w5p5
References
More Blogifier vulnerabilities
- TI-2022-16078 Blogifier v3.0 was discovered to contain an arbitrary file upload vulnerability at… CVSS 3.1MEDIUM 4.8
Sources
- CVE-2019-12277 · CVE Program
- CVE-2019-12277 · NVD
- FIRST EPSS
- GHSA-qcx4-gfh8-w5p5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences