In Rancher 2 through 2.2.3, Project owners can inject additional fluentd configuration to…
Priority MEDIUM 42CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
In Rancher 2 through 2.2.3, Project owners can inject additional fluentd configuration to read files or execute arbitrary commands inside the fluentd container.
Why it matters now
EPSS 0.01976 80th percentileScored 2026-11-07
Fix Fixed github.com/rancher/rancher (Go): 2.2.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/rancher/rancher (Go) | 2.0.0 to before 2.2.4 | 2.2.4 | Patch available | GHSA-53pj-67m4-9w98 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/rancher/rancher (Go) Vendor— Affected 2.0.0 to before 2.2.4 Fixed in 2.2.4 Patch available GHSA-53pj-67m4-9w98
Remediation
- Fix · GHSA-53pj-67m4-9w98 github.com/rancher/rancher (Go) Fixed in 2.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-12303
- 2026-10-03 Alias added: GHSA-53pj-67m4-9w98
References
More SUSE Rancher vulnerabilities
- TI-2021-14903 Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object CVSS 3.1CRITICAL 9.9
- TI-2022-21489 Rancher: Non-random authentication token CVSS 3.1CRITICAL 9.8
- TI-2019-08380 An issue was discovered that affects the following versions of Rancher: v2.0.0 through… CVSS 3.0CRITICAL 9.8
- TI-2023-08827 Improper privilege management in SUSE Rancher CVSS 3.1CRITICAL 9.9
- TI-2023-08823 Improper privilege management in SUSE Rancher CVSS 3.1CRITICAL 9.9
- TI-2022-21491 Rancher: Exposure of sensitive fields CVSS 3.1CRITICAL 9.9
Sources
- CVE-2019-12303 · CVE Program
- CVE-2019-12303 · NVD
- FIRST EPSS
- GHSA-53pj-67m4-9w98 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences