An issue was discovered in Django 1.11 before 1.11.21, 2.1 before 2.1.9, and 2.2 before…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
An issue was discovered in Django 1.11 before 1.11.21, 2.1 before 2.1.9, and 2.2 before 2.2.2. The clickable Current URL value displayed by the AdminURLFieldWidget displays the provided value without validating it as a safe URL. Thus, an unvalidated value stored in the database, or a value provided as a URL query parameter payload, could result in an clickable JavaScript link.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | 1.11a1 to before 1.11.21 | 1.11.21 | Patch available | GHSA-7rp2-fm2h-wchj |
| — | Django (PyPI) | 2.1a1 to before 2.1.9 | 2.1.9 | Patch available | GHSA-7rp2-fm2h-wchj |
| — | Django (PyPI) | 2.2a1 to before 2.2.2 | 2.2.2 | Patch available | GHSA-7rp2-fm2h-wchj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected 1.11a1 to before 1.11.21 Fixed in 1.11.21 Patch available GHSA-7rp2-fm2h-wchj
- Django (PyPI) Vendor— Affected 2.1a1 to before 2.1.9 Fixed in 2.1.9 Patch available GHSA-7rp2-fm2h-wchj
- Django (PyPI) Vendor— Affected 2.2a1 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-7rp2-fm2h-wchj
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 1.11 to before 1.11.21; 2.1 to before 2.1.9; 2.2 to before 2.2.2 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 1.11 to before 1.11.21; 2.1 to before 2.1.9; 2.2 to before 2.2.2 Vulnerable ·djangoproject
Remediation
- Fix · GHSA-7rp2-fm2h-wchj Django (PyPI) Fixed in 1.11.21 Advisory →
- Fix · GHSA-7rp2-fm2h-wchj Django (PyPI) Fixed in 2.1.9 Advisory →
- Fix · GHSA-7rp2-fm2h-wchj Django (PyPI) Fixed in 2.2.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 14 (Rocky) | Affected | No fix yet |
| Red Hat Storage 3 | Affected | No fix planned: Will not fix |
Not affected: 13 products
- Red Hat Ceph Storage 2
- Red Hat Ceph Storage 3
- Red Hat Certification for Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux OpenStack Platform 7 (Kilo)
- Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) Operational Tools
- Red Hat OpenStack Platform 10 (Newton)
- Red Hat OpenStack Platform 15 (Stein)
- Red Hat OpenStack Platform 8 (Liberty)
- Red Hat OpenStack Platform 8 (Liberty) Operational Tools
- Red Hat OpenStack Platform 9 (Mitaka)
- Red Hat OpenStack Platform 9 (Mitaka) Operational Tools
- Red Hat Satellite 6
- Red Hat Update Infrastructure 3 for Cloud Providers
Timeline
- 2026-10-02 Threatist record created from CVE-2019-12308
- 2026-10-03 Alias added: GHSA-7rp2-fm2h-wchj
References
Advisory 14
- https://docs.djangoproject.com/en/dev/releases/security/
- [oss-security] 20190603 Django: CVE-2019-12308 AdminURLFieldWidget XSS (plus patched bundled jQuery for CVE-2019-11358)
- https://docs.djangoproject.com/en/dev/releases/1.11.21/
- https://docs.djangoproject.com/en/dev/releases/2.1.9/
- https://docs.djangoproject.com/en/dev/releases/2.2.2/
- https://www.djangoproject.com/weblog/2019/jun/03/security-releases/
- FEDORA-2019-57a4324120
- USN-4043-1
- DSA-4476
- openSUSE-SU-2019:1839
- openSUSE-SU-2019:1872
- GLSA-202004-17
- https://nvd.nist.gov/vuln/detail/CVE-2019-12308
- https://github.com/advisories/GHSA-7rp2-fm2h-wchj
Other 17
- https://groups.google.com/forum/#%21topic/django-announce/GEbHU7YoVz8
- [debian-lts-announce] 20190605 [SECURITY] [DLA 1814-1] python-django security update
- [debian-lts-announce] 20190701 [SECURITY] [DLA 1842-1] python-django security update
- 20190708 [SECURITY] [DSA 4476-1] python-django security update
- https://github.com/django/django/commit/09186a13d975de6d049f8b3e05484f66b01ece62
- https://github.com/django/django/commit/afddabf8428ddc89a332f7a78d0d21eaf2b5a673
- https://github.com/django/django/commit/c238701859a52d584f349cce15d56c8e8137c52b
- https://www.djangoproject.com/weblog/2019/jun/03/security-releases
- https://usn.ubuntu.com/4043-1
- https://lists.fedoraproject.org/archives/list/[email protected]/message/USYRARSYB7PE3S2ZQO7PZNWMH7RPGL5G
- https://groups.google.com/forum/#!topic/django-announce/GEbHU7YoVz8
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2019-79.yaml
- https://github.com/django/django
- https://docs.djangoproject.com/en/dev/releases/security
- https://docs.djangoproject.com/en/dev/releases/2.2.2
- https://docs.djangoproject.com/en/dev/releases/2.1.9
- https://docs.djangoproject.com/en/dev/releases/1.11.21
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-12308 · CVE Program
- CVE-2019-12308 · NVD
- FIRST EPSS
- GHSA-7rp2-fm2h-wchj · GitHub Advisory Database · CC BY 4.0
- CVE-2019-12308 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences